summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-04 02:57:22 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-04 02:57:22 +0000
commitc6f044b0ad45606cde4a5977c591f48c4b368b08 (patch)
treec08c4c60e8d301d5c7d1e09f77a4e7e13c4122d9 /sys-kernel
parentmask new gentoo-sources (diff)
downloadgentoo-2-c6f044b0ad45606cde4a5977c591f48c4b368b08.tar.gz
gentoo-2-c6f044b0ad45606cde4a5977c591f48c4b368b08.tar.bz2
gentoo-2-c6f044b0ad45606cde4a5977c591f48c4b368b08.zip
New version of gentoo-sources finally ready to roll!
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog12
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r92
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild114
3 files changed, 127 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 6d16b542c2d5..bd4c3d0ef3c7 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.3 2002/08/20 11:02:31 mjc Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.4 2002/09/04 02:57:22 lostlogic Exp $
+
+*gentoo-sources-2.4.19-r9 (03 Sep 2002)
+
+ 03 Sep 2002; Brandon Low <lostlogic@gentoo.org> gentoo-sources-2.4.19-r9.ebuild:
+
+ Whole new kernel patching methodology and new kernel.
+
+ I won't mark what has changed as that would be impossible,
+ instead read /usr/share/doc/gentoo-sources-2.4.19-r9/patches.txt.gz
+ for information about all the patches in this kernel.
*gentoo-sources-2.4.19-r8 (20 Aug 2002)
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r9 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r9
new file mode 100644
index 000000000000..23a241376d0f
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.19-r9
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 043051b5895d9b56bafa542fe5249a33 patches-2.4.19-gentoo-r9.tar.bz2 1330682
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild
new file mode 100644
index 000000000000..935fd4292862
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r9.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+OKV=2.4.19
+[ "${PR}" == "r0" ] && KV=${OKV}-gentoo || KV=${OKV}-gentoo-${PR}
+EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+#Documentation on the patches contained in this kernel will be installed
+#to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+if [ $ETYPE = "sources" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND="!build? ( >=sys-devel/binutils-2.11.90.0.31 )"
+ RDEPEND="${RDEPEND}
+ !build? ( >=sys-libs/ncurses-5.2
+ sys-devel/perl
+ >=sys-apps/modutils-2.4.2
+ sys-devel/make )"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -Os -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ # Now we need to deal with the tarball of patches.
+ cd ${KV} || die "No patch dir to change to"
+ [ `use crypto` ] || rm 8*
+ #Thers is some anti-grsecurity sentiment, so I'll
+ #make it easy not to patch it in.
+ #Uncomment the following line to not patch grsecurity.
+ #rm 14*
+
+ ./addpatches . ${WORKDIR}/linux-${KV} || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ # also fix the EXTRAVERSION
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make distclean || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ cat ${WORKDIR}/${KV}/docs/* > patches.txt
+ dodoc patches.txt
+ mv ${WORKDIR}/linux* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}