summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-02-26 17:28:25 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-02-26 17:28:25 +0000
commitaff57ad840a90cfb2cbf1dbc2d60e598105dfa92 (patch)
tree12e53be23ad7701c537af3bad0758b70ed49d4ae /sys-kernel
parentppc stable, bug #211230 (diff)
downloadgentoo-2-aff57ad840a90cfb2cbf1dbc2d60e598105dfa92.tar.gz
gentoo-2-aff57ad840a90cfb2cbf1dbc2d60e598105dfa92.tar.bz2
gentoo-2-aff57ad840a90cfb2cbf1dbc2d60e598105dfa92.zip
Revision bump for new genpatches.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog9
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r11.ebuild39
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.24-r3.ebuild40
3 files changed, 87 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 86ab2bbd0584..90435c7f636c 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.19 2008/02/21 10:49:20 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.20 2008/02/26 17:28:25 nelchael Exp $
+
+*tuxonice-sources-2.6.24-r3 (26 Feb 2008)
+*tuxonice-sources-2.6.23-r11 (26 Feb 2008)
+
+ 26 Feb 2008; Krzysiek Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.23-r11.ebuild, +tuxonice-sources-2.6.24-r3.ebuild:
+ Revision bump for new genpatches.
21 Feb 2008; Christian Faulhammer <opfer@gentoo.org>
tuxonice-sources-2.6.23-r10.ebuild:
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r11.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r11.ebuild
new file mode 100644
index 000000000000..53a0eb8d76f9
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.23-r11.ebuild,v 1.1 2008/02/26 17:28:25 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches http://www.tuxonice.net"
+
+TUXONICE_VERSION="3.0-rc5"
+TUXONICE_TARGET="2.6.23.16"
+TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}"
+TUXONICE_URI="http://www.tuxonice.net/downloads/all/${TUXONICE_SRC}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-0.7.2
+ >=sys-power/hibernate-script-1.97"
+
+K_EXTRAEINFO="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.24-r3.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.24-r3.ebuild
new file mode 100644
index 000000000000..aa5c8489bf81
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.24-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.24-r3.ebuild,v 1.1 2008/02/26 17:28:25 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="4"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~dsd/genpatches http://www.tuxonice.net"
+
+TUXONICE_VERSION="3.0-rc5"
+TUXONICE_TARGET="2.6.24"
+TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}"
+TUXONICE_URI="http://www.tuxonice.net/downloads/all/${TUXONICE_SRC}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.patch.bz2
+ ${FILESDIR}/${TUXONICE_TARGET}-${TUXONICE_VERSION}-userui-fix.patch"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-0.7.2
+ >=sys-power/hibernate-script-1.97"
+
+K_EXTRAEINFO="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}