summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-10-29 22:51:20 +0000
committerMatt Rickard <frogger@gentoo.org>2003-10-29 22:51:20 +0000
commita613d287f2fbadb4be09696a7612c8196fa76624 (patch)
tree094e21881c76bcdd7efc4065daa990f6fa32bdab /sys-kernel
parentVersion bump (diff)
downloadgentoo-2-a613d287f2fbadb4be09696a7612c8196fa76624.tar.gz
gentoo-2-a613d287f2fbadb4be09696a7612c8196fa76624.tar.bz2
gentoo-2-a613d287f2fbadb4be09696a7612c8196fa76624.zip
Version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-prepatch-sources/ChangeLog6
-rw-r--r--sys-kernel/vanilla-prepatch-sources/Manifest4
-rw-r--r--sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre82
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre8.ebuild46
4 files changed, 55 insertions, 3 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/ChangeLog b/sys-kernel/vanilla-prepatch-sources/ChangeLog
index a3c44c19e710..9fa7d16a72c1 100644
--- a/sys-kernel/vanilla-prepatch-sources/ChangeLog
+++ b/sys-kernel/vanilla-prepatch-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-kernel/vanilla-prepatch-sources
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.14 2003/10/14 06:20:56 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.15 2003/10/29 22:51:13 frogger Exp $
+
+ 29 Oct 2003; Matthew Rickard <frogger@gentoo.org>
+ vanilla-prepatch-sources-2.4.23_pre8:
+ Version bump.
*vanilla-prepatch-sources-2.4.23_pre7 (14 Oct 2003)
diff --git a/sys-kernel/vanilla-prepatch-sources/Manifest b/sys-kernel/vanilla-prepatch-sources/Manifest
index 2a38f727e281..473440e47cc7 100644
--- a/sys-kernel/vanilla-prepatch-sources/Manifest
+++ b/sys-kernel/vanilla-prepatch-sources/Manifest
@@ -1,6 +1,6 @@
MD5 a221dfef18f0ecbd05008837267abba8 vanilla-prepatch-sources-2.4.23_pre6.ebuild 1459
-MD5 9f23105e250a0f3a0a6985f06ccfccc2 vanilla-prepatch-sources-2.4.23_pre8.ebuild 1456
-MD5 01125d1bb365e7c04be8068394fdc5f7 ChangeLog 2647
+MD5 7d8454318f40a6f148395f04dd30dc85 vanilla-prepatch-sources-2.4.23_pre8.ebuild 1459
+MD5 5ae91a8fd27b98946e2b1aa23f101f32 ChangeLog 2650
MD5 ff23d4a5fdca6dc6bcb4a7ff5b3f6297 metadata.xml 450
MD5 9f23105e250a0f3a0a6985f06ccfccc2 vanilla-prepatch-sources-2.4.23_pre7.ebuild 1456
MD5 365e6e523e736666445ddb58a98f68e1 files/digest-vanilla-prepatch-sources-2.4.23_pre6 134
diff --git a/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre8 b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre8
new file mode 100644
index 000000000000..19465c8a5272
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/files/digest-vanilla-prepatch-sources-2.4.23_pre8
@@ -0,0 +1,2 @@
+MD5 75dc85149b06ac9432106b8941eb9f7b linux-2.4.22.tar.bz2 29528612
+MD5 5aa1b41689379e83ce59fa8d8f75862c patch-2.4.23-pre8.bz2 2063299
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre8.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre8.ebuild
new file mode 100644
index 000000000000..baff7d346a35
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre8.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.23_pre8.ebuild,v 1.1 2003/10/29 22:51:13 frogger Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.22"
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://kernel/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}