summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-12-19 23:46:32 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-12-19 23:46:32 +0000
commit9a55626814525b20da32e22cc05a4371d18842d9 (patch)
tree6e0d26c1fdbd2cdfbf7504c59a1e7409eee4a3ce /sys-kernel
parentChanged from tar.bz2 to tar.gz cause tar.bz2 seems to be broken :( (diff)
downloadgentoo-2-9a55626814525b20da32e22cc05a4371d18842d9.tar.gz
gentoo-2-9a55626814525b20da32e22cc05a4371d18842d9.tar.bz2
gentoo-2-9a55626814525b20da32e22cc05a4371d18842d9.zip
NEW LOLO-SOURCES
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/lolo-sources/ChangeLog10
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre52
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre5.ebuild55
3 files changed, 66 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index eb7b1bbb2abd..91e9427e0d07 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.22 2002/12/18 00:12:48 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.23 2002/12/19 23:46:32 lostlogic Exp $
+
+*lolo-sources-2.4.20.1_pre5 (19 Dec 2002)
+
+ 19 Dec 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.20.1_pre5.ebuild:
+ You ever get the feeling that the world is out to get you? Well it is...
+ I scrapped everything and started over based HEAVILY on Con Kolivas kernel from
+ http://kernel.kolivas.net. I think this will do much better at serving us all
+ than where we were headed before.
17 Dec 2002; Brandon Low <lostlogic@gentoo.org>:
Make all kernel-sources SLOT="${KV}"
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre5 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre5
new file mode 100644
index 000000000000..092264171762
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.20.1_pre5
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 8275490d17a97fbde86b1fe4d128bdaf patches-2.4.20-lolo-r1_pre5.tar.bz2 1208658
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre5.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre5.ebuild
new file mode 100644
index 000000000000..40517036547c
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/lolo-sources-2.4.20.1_pre5.ebuild,v 1.1 2002/12/19 23:46:32 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://lostlogicx.com/gentoo/patches-${KV}.tar.bz2"
+KEYWORDS="x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ [ `use crypt` ] || rm 8*
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a very beta"
+ einfo "patchset of the linux kernel sources."
+ einfo "If there are problems with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "lostlogic@gentoo.org"
+
+}