summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2009-01-24 22:25:18 +0000
committerGordon Malm <gengor@gentoo.org>2009-01-24 22:25:18 +0000
commit9986e8c47a9e2f8991cddcf4d9a1e8d1d5883bbd (patch)
tree404a8c8fbbe8fe86234a71e1af23cc120da79afc /sys-kernel
parentRules update. (diff)
downloadgentoo-2-9986e8c47a9e2f8991cddcf4d9a1e8d1d5883bbd.tar.gz
gentoo-2-9986e8c47a9e2f8991cddcf4d9a1e8d1d5883bbd.tar.bz2
gentoo-2-9986e8c47a9e2f8991cddcf4d9a1e8d1d5883bbd.zip
Add hardened-sources-2.6.27-r6 release
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-hardened-r5-rc1-2009012401 i686)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.27-r6.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 59b5be189354..5dbc92129eb2 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.278 2009/01/24 16:36:28 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.279 2009/01/24 22:25:18 gengor Exp $
+
+*hardened-sources-2.6.27-r6 (24 Jan 2009)
+
+ 24 Jan 2009; Gordon Malm <gengor@gentoo.org>
+ +hardened-sources-2.6.27-r6.ebuild:
+ Revert PaX test29 to test30 changes. Fixes bug 256226.
*hardened-sources-2.6.27-r5 (24 Jan 2009)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.27-r6.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r6.ebuild
new file mode 100644
index 000000000000..13d5dff462db
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.27-r6.ebuild,v 1.1 2009/01/24 22:25:18 gengor Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="10"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-7"
+HGPV_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.1.12*"
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.24,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with kernel series ${OKV}."
+ ewarn "Therefore, it is strongly recommended that the following command is"
+ ewarn "issued prior to booting a ${P} series kernel for"
+ ewarn "the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}