summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-01-29 20:08:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-01-29 20:08:11 +0000
commit93be8c647046ce5ee03a80f09120a75f58d173e8 (patch)
tree6ffbd71f85bb066640bde532d79d83f409e5b322 /sys-kernel
parentRevision bump. Upstream patchs add lithuania to euro zone, spotted by Andreas... (diff)
downloadgentoo-2-93be8c647046ce5ee03a80f09120a75f58d173e8.tar.gz
gentoo-2-93be8c647046ce5ee03a80f09120a75f58d173e8.tar.bz2
gentoo-2-93be8c647046ce5ee03a80f09120a75f58d173e8.zip
vanilla-3.2.66 + genpatches-3.2-16 + grsecurity-3.0-3.2.66-201501272306
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.66-r4.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index b4c325b05b80..4d4f163746ff 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1207 2015/01/23 23:59:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1208 2015/01/29 20:08:11 blueness Exp $
+
+*hardened-sources-3.2.66-r4 (29 Jan 2015)
+
+ 29 Jan 2015; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.66-r4.ebuild:
+ vanilla-3.2.66 + genpatches-3.2-16 + grsecurity-3.0-3.2.66-201501272306
*hardened-sources-3.18.3 (24 Jan 2015)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.66-r4.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.66-r4.ebuild
new file mode 100644
index 000000000000..6e54e3ddbd45
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.66-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.66-r4.ebuild,v 1.1 2015/01/29 20:08:11 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-5"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}