summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2014-05-21 23:25:37 +0000
committerMike Pagano <mpagano@gentoo.org>2014-05-21 23:25:37 +0000
commit7f4a65be17ccd1da63561621ca72c1f9d3cebc21 (patch)
tree1bfc5ecaeef2215fbcc72c3a2fd2d683428c3ba7 /sys-kernel
parentRestore CC & CXX exports as they are necessary for the native ABI, bug #510980. (diff)
downloadgentoo-2-7f4a65be17ccd1da63561621ca72c1f9d3cebc21.tar.gz
gentoo-2-7f4a65be17ccd1da63561621ca72c1f9d3cebc21.tar.bz2
gentoo-2-7f4a65be17ccd1da63561621ca72c1f9d3cebc21.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B576E4E3)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/ChangeLog8
-rw-r--r--sys-kernel/git-sources/git-sources-3.15_rc6.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-kernel/git-sources/ChangeLog b/sys-kernel/git-sources/ChangeLog
index 199982f6ab2c..cfe90fc63344 100644
--- a/sys-kernel/git-sources/ChangeLog
+++ b/sys-kernel/git-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/git-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1385 2014/05/09 21:38:19 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/ChangeLog,v 1.1386 2014/05/21 23:25:37 mpagano Exp $
+
+*git-sources-3.15_rc6 (21 May 2014)
+
+ 21 May 2014; Michael Pagano <mpagano@gentoo.org>
+ +git-sources-3.15_rc6.ebuild:
+ Version bump
*git-sources-3.15_rc5 (09 May 2014)
diff --git a/sys-kernel/git-sources/git-sources-3.15_rc6.ebuild b/sys-kernel/git-sources/git-sources-3.15_rc6.ebuild
new file mode 100644
index 000000000000..d6efa17741ed
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-3.15_rc6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/git-sources/git-sources-3.15_rc6.ebuild,v 1.1 2014/05/21 23:25:37 mpagano Exp $
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE=0
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="http://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at http://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.1-r3"
+
+pkg_postinst() {
+ postinst_sources
+}