summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBob Johnson <livewire@gentoo.org>2003-01-31 03:06:38 +0000
committerBob Johnson <livewire@gentoo.org>2003-01-31 03:06:38 +0000
commit7d3ad6df5aedb2c5679fc2472a28670fa2e158b2 (patch)
treebe9a7af24a87aa8dc8d9b1f084b33f505840f01e /sys-kernel
parentGNOME 2.2 RC2 (diff)
downloadgentoo-2-7d3ad6df5aedb2c5679fc2472a28670fa2e158b2.tar.gz
gentoo-2-7d3ad6df5aedb2c5679fc2472a28670fa2e158b2.tar.bz2
gentoo-2-7d3ad6df5aedb2c5679fc2472a28670fa2e158b2.zip
new ebuild
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/xfs-sources/ChangeLog24
-rw-r--r--sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre62
-rw-r--r--sys-kernel/xfs-sources/xfs-sources-2.4.20_pre6.ebuild67
3 files changed, 85 insertions, 8 deletions
diff --git a/sys-kernel/xfs-sources/ChangeLog b/sys-kernel/xfs-sources/ChangeLog
index 822e21c861a4..a5d1d47cd18e 100644
--- a/sys-kernel/xfs-sources/ChangeLog
+++ b/sys-kernel/xfs-sources/ChangeLog
@@ -1,13 +1,21 @@
# ChangeLog for sys-kernel/xfs-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.18 2003/01/30 04:38:12 livewire Exp $
-
-*xfs-sources-2.4.20_pre5 (29 Jan 2003)
-
- 29 Jan 2003; Bob Johnson <livewire@gentoo.org>
-
- - fix eepro100 compile
-
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/ChangeLog,v 1.19 2003/01/31 03:06:38 livewire Exp $
+
+*xfs-sources-2.4.20_pre6 (30 Jan 2003)
+
+ 30 Jan 2003; Bob Johnson <livewire@gentoo.org>
+
+ - Newest Aic79xx and Aic7xxx
+ - bcm 4400 and 5700 nic drivers
+ - fixed mki adapter build
+ - preliminary Nforce2 ide support
+ - nforce 810 audio fix
+ - eepro100 compile fix
+ - Adaptec firmware patch
+ - in2000 and ncr scsi compile fixes
+ - pull via-rhine,winbond,yellowfin,starfire,hamachi updates
+
*xfs-sources-2.4.20_pre5 (14 Jan 2003)
14 Jan 2003; Bob Johnson <livewire@gentoo.org>:
diff --git a/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre6 b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre6
new file mode 100644
index 000000000000..16165c8cd583
--- /dev/null
+++ b/sys-kernel/xfs-sources/files/digest-xfs-sources-2.4.20_pre6
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 f737ae6154fcbead8d84c020c2734ef0 patches-2.4.20-xfs_pre6.tar.bz2 3262742
diff --git a/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre6.ebuild b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre6.ebuild
new file mode 100644
index 000000000000..7f45283c5d89
--- /dev/null
+++ b/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xfs-sources/xfs-sources-2.4.20_pre6.ebuild,v 1.1 2003/01/31 03:06:38 livewire Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV=2.4.20
+EXTRAVERSION=-${P/-sources-2.4.20}
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/xfs-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the XFS Specialized Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+KEYWORDS="~x86 -ppc -sparc "
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3, check out the special"
+ einfo "processor types just for you"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC and patch-int
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 8*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}