summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 08:39:59 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 08:39:59 +0000
commit7941584b8246f0b4d56123c0980dc2d4c189a255 (patch)
tree6892df6ac51b5ef399f01be48d1d2f27995ec744 /sys-kernel
parentnew version (diff)
downloadgentoo-2-7941584b8246f0b4d56123c0980dc2d4c189a255.tar.gz
gentoo-2-7941584b8246f0b4d56123c0980dc2d4c189a255.tar.bz2
gentoo-2-7941584b8246f0b4d56123c0980dc2d4c189a255.zip
2.2.22
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-sources/ChangeLog8
-rw-r--r--sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.2.221
-rw-r--r--sys-kernel/vanilla-sources/vanilla-sources-2.2.22.ebuild100
3 files changed, 107 insertions, 2 deletions
diff --git a/sys-kernel/vanilla-sources/ChangeLog b/sys-kernel/vanilla-sources/ChangeLog
index 2ab35bdef473..6a345c3e1e72 100644
--- a/sys-kernel/vanilla-sources/ChangeLog
+++ b/sys-kernel/vanilla-sources/ChangeLog
@@ -1,8 +1,9 @@
# ChangeLog for sys-kernel/vanilla-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/ChangeLog,v 1.4 2002/08/12 06:12:06 jmorgan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/ChangeLog,v 1.5 2002/11/17 08:39:59 vapier Exp $
*vanilla-sources-2.4.18 (12 Aug 2002)
+
12 Aug 2002; Jack Morgan <jmorgan@gentoo.org>
Added arch keywords (sparc64)
@@ -18,6 +19,9 @@
Added arch keywords (x86 ppc)
09 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> ChangeLog :
-
Added ChangeLog.
+*vanilla-sources-2.2.22 (17 Nov 2002)
+
+ 17 Nov 2002; Mike Frysinger <vapier@gentoo.org>
+ Some people like old school kernels
diff --git a/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.2.22 b/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.2.22
new file mode 100644
index 000000000000..855d7cef95b7
--- /dev/null
+++ b/sys-kernel/vanilla-sources/files/digest-vanilla-sources-2.2.22
@@ -0,0 +1 @@
+MD5 94a837594d00481a8087df2d6b6eb02f linux-2.2.22.tar.bz2 15815361
diff --git a/sys-kernel/vanilla-sources/vanilla-sources-2.2.22.ebuild b/sys-kernel/vanilla-sources/vanilla-sources-2.2.22.ebuild
new file mode 100644
index 000000000000..d6d054ba3da1
--- /dev/null
+++ b/sys-kernel/vanilla-sources/vanilla-sources-2.2.22.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-sources/vanilla-sources-2.2.22.ebuild,v 1.1 2002/11/17 08:39:59 vapier Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.2.22
+KV=2.2.22
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# stock 2.2.22 kernel sources
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.2/linux-${OKV}.tar.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}