summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-14 07:23:05 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-14 07:23:05 +0000
commit77272c5fd774ef9bf89433d19e3fca3559b69438 (patch)
treec551a84b11f1162f59bef97d6b3f1203d9b6a8ab /sys-kernel
parent0.32.0_p1 version bump (bug #296526). (diff)
downloadgentoo-2-77272c5fd774ef9bf89433d19e3fca3559b69438.tar.gz
gentoo-2-77272c5fd774ef9bf89433d19e3fca3559b69438.tar.bz2
gentoo-2-77272c5fd774ef9bf89433d19e3fca3559b69438.zip
[zen-sources] version bumps: 2.6.30_p11 (final), 2.6.32_p1
(Portage version: 2.2_rc59/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/zen-sources/ChangeLog9
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.30_p11.ebuild52
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.32_p1.ebuild52
3 files changed, 112 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index 1c7f0e04f0b7..b607566181ce 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.13 2009/11/30 19:42:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.14 2009/12/14 07:23:05 wired Exp $
+
+*zen-sources-2.6.32_p1 (14 Dec 2009)
+*zen-sources-2.6.30_p11 (14 Dec 2009)
+
+ 14 Dec 2009; Alex Alexander <wired@gentoo.org>
+ +zen-sources-2.6.30_p11.ebuild, +zen-sources-2.6.32_p1.ebuild:
+ version bumps: 2.6.30_p11 (final), 2.6.32_p1
*zen-sources-2.6.31_p9 (30 Nov 2009)
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.30_p11.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.30_p11.ebuild
new file mode 100644
index 000000000000..bb5ed5e4bbf1
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.30_p11.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+RESTRICT="binchecks strip primaryuri mirror"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.32_p1.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.32_p1.ebuild
new file mode 100644
index 000000000000..bb5ed5e4bbf1
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.32_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+RESTRICT="binchecks strip primaryuri mirror"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"