summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2005-10-05 20:07:28 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2005-10-05 20:07:28 +0000
commit68cb792412748ee55cf3f754e1d73536e4c47f14 (patch)
tree043fb7647cff6f8de2cf0c681e1c22a079d22d39 /sys-kernel
parentRevbump to build ssindex for beagle. bug #108177 (diff)
downloadgentoo-2-68cb792412748ee55cf3f754e1d73536e4c47f14.tar.gz
gentoo-2-68cb792412748ee55cf3f754e1d73536e4c47f14.tar.bz2
gentoo-2-68cb792412748ee55cf3f754e1d73536e4c47f14.zip
2.4.29 & 2.4.31-r1 cleanup
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog7
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.292
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31-r12
-rw-r--r--sys-kernel/sparc-sources/files/generate-asm-sparc80
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild40
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.31-r1.ebuild37
6 files changed, 6 insertions, 162 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 8004af080ac5..56adfca63360 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.88 2005/10/05 20:03:10 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.89 2005/10/05 20:07:28 gustavoz Exp $
+
+ 05 Oct 2005; Gustavo Zacarias <gustavoz@gentoo.org>
+ -files/generate-asm-sparc, -sparc-sources-2.4.29.ebuild,
+ -sparc-sources-2.4.31-r1.ebuild:
+ 2.4.29 & 2.4.31-r1 cleanup
05 Oct 2005; Gustavo Zacarias <gustavoz@gentoo.org>
sparc-sources-2.4.31-r2.ebuild:
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29
deleted file mode 100644
index 8411be570369..000000000000
--- a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.29
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 fcf8b6bb620467f27b657c1c4a60bbff linux-2.4.29.tar.bz2 31124710
-MD5 e19cf457095186f372b92fbe84042792 patches-2.4.29-sparc.tar.bz2 184046
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31-r1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31-r1
deleted file mode 100644
index 07e1d824ccb4..000000000000
--- a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.31-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 bf6e3843ca122e3ad9ad28b94f4b8ed5 linux-2.4.31.tar.bz2 31129841
-MD5 6e7de0045148dcd25457c89dec4269e2 patches-2.4.31-sparc-r1.tar.bz2 182428
diff --git a/sys-kernel/sparc-sources/files/generate-asm-sparc b/sys-kernel/sparc-sources/files/generate-asm-sparc
deleted file mode 100644
index cac5f8beb11a..000000000000
--- a/sys-kernel/sparc-sources/files/generate-asm-sparc
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/sh -e
-#
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/files/generate-asm-sparc,v 1.5 2004/07/18 04:48:52 dragonheart Exp $
-#
-# This script generates the files in /usr/include/asm for sparc systems
-# during installation of sys-kernel/linux-headers.
-# Will no longer be needed when full 64 bit support is used on sparc64
-# systems.
-#
-# Shamefully ripped from Debian
-# ----------------------------------------------------------------------
-
-# Idea borrowed from RedHat's kernel package
-
-if [ -n "$1" ]; then
- if [ ! -d "$1" ]; then
- echo "$1" does not exist, or is not a directory
- exit 1
- fi
- cd $1
-else
- cd /usr/include
-fi
-
-if [ ! -d asm-sparc -o ! -d asm-sparc64 ] ; then
- echo E: asm-sparc and asm-sparc64 must exist, or you will have problems
- exit 1
-fi
-
-rm -rf asm
-mkdir asm
-
-for h in `( ls asm-sparc; ls asm-sparc64 ) | grep '\.h$' | sort -u`; do
- name=`echo $h | tr a-z. A-Z_`
- # common header
- cat > asm/$h << EOF
-/* All asm/ files are generated and point to the corresponding
- * file in asm-sparc or asm-sparc64. To regenerate, run "generate-asm"
- */
-
-#ifndef __SPARCSTUB__${name}__
-#define __SPARCSTUB__${name}__
-
-EOF
-
- # common for sparc and sparc64
- if [ -f asm-sparc/$h -a -f asm-sparc64/$h ]; then
- cat >> asm/$h <<EOF
-#ifdef __arch64__
-#include <asm-sparc64/$h>
-#else
-#include <asm-sparc/$h>
-#endif
-EOF
-
- # sparc only
- elif [ -f asm-sparc/$h ]; then
- cat >> asm/$h <<EOF
-#ifndef __arch64__
-#include <asm-sparc/$h>
-#endif
-EOF
- # sparc64 only
- else
- cat >> asm/$h <<EOF
-#ifdef __arch64__
-#include <asm-sparc64/$h>
-#endif
-EOF
- fi
-
- # common footer
- cat >> asm/$h <<EOF
-
-#endif /* !__SPARCSTUB__${name}__ */
-EOF
-
-done
-
-exit 0
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild
deleted file mode 100644
index 749564168c9a..000000000000
--- a/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.29.ebuild,v 1.4 2005/03/06 19:21:57 gustavoz Exp $
-
-ETYPE="sources"
-IUSE="livecd ultra1"
-inherit kernel-2
-detect_version
-
-PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
-
-SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
-
-KEYWORDS="-* sparc"
-DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
-UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2
- ${FILESDIR}/2.4-sparc64-ramdisk64.patch
- ${FILESDIR}/blade1500.patch"
-SRC_URI="${KERNEL_URI} ${SSV_URI}"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
-
-pkg_setup() {
- use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
- use livecd || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE}
- 2.4-sparc64-ramdisk64.patch"
-}
-
-pkg_postinst() {
- postinst_sources
-
- if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
- einfo
- einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
- einfo "please emerge the kernel using the following command:"
- einfo
- einfo "USE=ultra1 emerge sparc-sources"
- einfo
- fi
-
-}
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.31-r1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.31-r1.ebuild
deleted file mode 100644
index f7826a8f6269..000000000000
--- a/sys-kernel/sparc-sources/sparc-sources-2.4.31-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.31-r1.ebuild,v 1.1 2005/09/06 22:12:02 gustavoz Exp $
-
-ETYPE="sources"
-IUSE="livecd ultra1"
-inherit kernel-2
-detect_version
-
-PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
-
-SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
-
-KEYWORDS="-* ~sparc"
-DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
-UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
-SRC_URI="${KERNEL_URI} ${SSV_URI}"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
-
-pkg_setup() {
- use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
- use livecd || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 5000_sparc64-ramdisk64.patch"
-}
-
-pkg_postinst() {
- postinst_sources
-
- if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
- einfo
- einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
- einfo "please emerge the kernel using the following command:"
- einfo
- einfo "USE=ultra1 emerge sparc-sources"
- einfo
- fi
-
-}