summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2006-08-28 18:35:05 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2006-08-28 18:35:05 +0000
commit5f5bfa7ee4da0b0f2bc6731d28f0ada934ab7b9c (patch)
tree1fe62bf2ee877210e37949c4ccbfc86461667c20 /sys-kernel
parentStable on amd64/x86. (diff)
downloadgentoo-2-5f5bfa7ee4da0b0f2bc6731d28f0ada934ab7b9c.tar.gz
gentoo-2-5f5bfa7ee4da0b0f2bc6731d28f0ada934ab7b9c.tar.bz2
gentoo-2-5f5bfa7ee4da0b0f2bc6731d28f0ada934ab7b9c.zip
squashfs 3.1 and minor kernel symbol exhaustion fix
(Portage version: 2.1-r2)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.2-r17
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.33.2-r1.ebuild36
3 files changed, 50 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 0e59e761346b..4729f679ac36 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.105 2006/08/25 15:18:38 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.106 2006/08/28 18:35:04 gustavoz Exp $
+
+*sparc-sources-2.4.33.2-r1 (28 Aug 2006)
+
+ 28 Aug 2006; Gustavo Zacarias <gustavoz@gentoo.org>
+ -sparc-sources-2.4.33.2.ebuild, +sparc-sources-2.4.33.2-r1.ebuild:
+ squashfs 3.1 and minor kernel symbol exhaustion fix
*sparc-sources-2.4.33.2 (25 Aug 2006)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.2-r1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.2-r1
new file mode 100644
index 000000000000..6c505da1902c
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.33.2-r1
@@ -0,0 +1,7 @@
+RMD160 6acdabafecfdc69f3f5b0203eac154ac1c39c44b linux-2.4.33.tar.bz2 31161078
+SHA256 a1d8403a72dbe7a4d63986e71e22e6eeb32fe2e2e949f40c3f9f3bb6496ee47a linux-2.4.33.tar.bz2 31161078
+RMD160 e6c2aa41ab29b43d3ed4410b2cd29448ccf51a89 patch-2.4.33.2.bz2 3799
+SHA256 8ed6a4840ef76b857502f37a06963d21710d9429d3399a4973d72a38c81c5afb patch-2.4.33.2.bz2 3799
+MD5 7426892f63404c9efcdaf430587acbc7 patches-2.4.33.2-sparc-r1.tar.bz2 197259
+RMD160 3003a4ca9e3b9707d269b7259d6bd3cdc325473d patches-2.4.33.2-sparc-r1.tar.bz2 197259
+SHA256 f840d779ae491938ebb9ef80bfea7f629d5a63fc004619e7737dfaebc20d5ce9 patches-2.4.33.2-sparc-r1.tar.bz2 197259
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.33.2-r1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.33.2-r1.ebuild
new file mode 100644
index 000000000000..9fb151211a20
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.33.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.33.2-r1.ebuild,v 1.1 2006/08/28 18:35:05 gustavoz Exp $
+
+ETYPE="sources"
+IUSE="ultra1"
+inherit kernel-2
+detect_version
+
+PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
+
+SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
+
+KEYWORDS="-* ~sparc"
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
+SRC_URI="${KERNEL_URI} ${SSV_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
+
+pkg_setup() {
+ use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+
+}