summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2015-04-15 10:11:36 +0000
committerStratos Psomadakis <psomas@gentoo.org>2015-04-15 10:11:36 +0000
commit5c0caa918aad73327628cba774784a14ed698716 (patch)
tree7046fc4ddbfb734ce123d446c963d97ed3cfd886 /sys-kernel
parentbump; ebuild by Alex Xu provided from bug #545504, builds and installs, runte... (diff)
downloadgentoo-2-5c0caa918aad73327628cba774784a14ed698716.tar.gz
gentoo-2-5c0caa918aad73327628cba774784a14ed698716.tar.bz2
gentoo-2-5c0caa918aad73327628cba774784a14ed698716.zip
Version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BC35D737)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rt-sources/ChangeLog11
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild46
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild46
3 files changed, 101 insertions, 2 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index fe7f585bc69f..a144ac02a8f4 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/rt-sources
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.30 2014/12/12 16:01:39 psomas Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.31 2015/04/15 10:11:36 psomas Exp $
+
+*rt-sources-3.18.11_p7 (15 Apr 2015)
+*rt-sources-3.14.36_p34 (15 Apr 2015)
+
+ 15 Apr 2015; Stratos Psomadakis <psomas@gentoo.org>
+ +rt-sources-3.14.36_p34.ebuild, +rt-sources-3.18.11_p7.ebuild:
+ Version bump
*rt-sources-3.14.25_p22 (12 Dec 2014)
diff --git a/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild b/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild
new file mode 100644
index 000000000000..f801627c01bb
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.14.36_p34.ebuild,v 1.1 2015/04/15 10:11:36 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild b/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild
new file mode 100644
index 000000000000..105243667654
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.18.11_p7.ebuild,v 1.1 2015/04/15 10:11:36 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."