summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-09-22 09:46:07 +0000
committerPacho Ramos <pacho@gentoo.org>2012-09-22 09:46:07 +0000
commit2f044247341c8923de52f432e39aa27777d8c6c0 (patch)
tree0d6c97006c3227553b49f7eef8ebd137845714a2 /sys-kernel
parentVersion bump, drop old. (diff)
downloadgentoo-2-2f044247341c8923de52f432e39aa27777d8c6c0.tar.gz
gentoo-2-2f044247341c8923de52f432e39aa27777d8c6c0.tar.bz2
gentoo-2-2f044247341c8923de52f432e39aa27777d8c6c0.zip
Version bump.
(Portage version: 2.1.11.19/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog9
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.43.ebuild40
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.4.11.ebuild38
3 files changed, 86 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 5eeda41d7ab1..e186b802751f 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.147 2012/09/15 10:13:17 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.148 2012/09/22 09:46:07 pacho Exp $
+
+*tuxonice-sources-3.0.43 (22 Sep 2012)
+*tuxonice-sources-3.4.11 (22 Sep 2012)
+
+ 22 Sep 2012; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.0.43.ebuild,
+ +tuxonice-sources-3.4.11.ebuild:
+ Version bump.
*tuxonice-sources-3.4.10 (15 Sep 2012)
*tuxonice-sources-3.3.8-r1 (15 Sep 2012)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.43.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.43.ebuild
new file mode 100644
index 000000000000..9774cae88209
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.43.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.43.ebuild,v 1.1 2012/09/22 09:46:07 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="30"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.11.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.11.ebuild
new file mode 100644
index 000000000000..9ad1729696c7
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.11.ebuild,v 1.1 2012/09/22 09:46:07 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="12"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20120721"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.4"
+TUXONICE_URI="http://dev.gentoo.org/~pacho/tuxonice/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SNAPSHOT}-TuxOnIce-for-Linux-${TUXONICE_TARGET}.patch.bz2"
+UNIPATCH_STRICTORDER="yes"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"