summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-03-01 00:30:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-03-01 00:30:13 +0000
commit1f1800642630af6f6a15cacb707cec9ce31641a1 (patch)
tree27de3a81aeb060bc675b546ef41ea36b08278fcf /sys-kernel
parentauto enable e500-double for ppc targets when possible #353380 by Alexander Dubov (diff)
downloadgentoo-2-1f1800642630af6f6a15cacb707cec9ce31641a1.tar.gz
gentoo-2-1f1800642630af6f6a15cacb707cec9ce31641a1.tar.bz2
gentoo-2-1f1800642630af6f6a15cacb707cec9ce31641a1.zip
Based on vanilla 2.6.32.29 + genpatches-2.6.32-31 + grsecurity-2.2.1-2.6.32.29-201102271552
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r39.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 73b3991e3fb0..90a9e9105f1e 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.391 2011/02/21 18:05:59 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.392 2011/03/01 00:30:13 blueness Exp $
+
+*hardened-sources-2.6.32-r39 (01 Mar 2011)
+
+ 01 Mar 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r39.ebuild:
+ Based on vanilla 2.6.32.29 + genpatches-2.6.32-31 +
+ grsecurity-2.2.1-2.6.32.29-201102271552
*hardened-sources-2.6.37-r3 (21 Feb 2011)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r39.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r39.ebuild
new file mode 100644
index 000000000000..ee0ee950e29e
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r39.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r39.ebuild,v 1.1 2011/03/01 00:30:13 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="31"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-42"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}