summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Pfeifer <pfeifer@gentoo.org>2003-03-19 06:14:24 +0000
committerJay Pfeifer <pfeifer@gentoo.org>2003-03-19 06:14:24 +0000
commit16b73689ebaecac5b2e932fcd4b8988b14c29598 (patch)
treebd0068b88f5711a51aa695766b3f4c96cf1fbc45 /sys-kernel
parentfix bug 17799 in hotplug (diff)
downloadgentoo-2-16b73689ebaecac5b2e932fcd4b8988b14c29598.tar.gz
gentoo-2-16b73689ebaecac5b2e932fcd4b8988b14c29598.tar.bz2
gentoo-2-16b73689ebaecac5b2e932fcd4b8988b14c29598.zip
Bumped for ptrace security fix and other fixes.
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog18
-rw-r--r--sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r22
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r2.ebuild82
3 files changed, 101 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 644bbc14bb5e..ddc989db9d41 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.18 2003/02/27 23:28:44 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.19 2003/03/19 06:14:24 pfeifer Exp $
+
+*gentoo-sources-2.4.20-r2 (19 Mar 2003)
+
+ 19 Mar 2003; Jay Pfeifer <pfeifer@gentoo.org> gentoo-sources-2.4.20-r2.ebuild:
+ Package is currently marked unstable.
+
+ * Added ptrace security fix.
+ * Process priorities are now obeyed. :)
+ * pom updated to 20030310
+ * removed aavm
+ * removed ck4 O(1) sched, ll, preempt patch
+ * added rml preempt & ll
+ * update xattr+acl to xattr+acl+trusted 0.8.55
+ * update usbdnet
+ * add dac960 root fix
+ * add sim710 compile fix
*gentoo-sources-2.4.20-r1 (12 Jan 2003)
diff --git a/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r2 b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r2
new file mode 100644
index 000000000000..d9aa743143c5
--- /dev/null
+++ b/sys-kernel/gentoo-sources/files/digest-gentoo-sources-2.4.20-r2
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 98ab92f3997b75cfe80676712863fc25 patches-2.4.20-gentoo-r2.tar.bz2 2519990
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r2.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r2.ebuild
new file mode 100644
index 000000000000..861ecfdd1fb2
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.20-r2.ebuild,v 1.1 2003/03/19 06:14:24 pfeifer Exp $
+
+IUSE="build crypt xfs"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+
+inherit kernel || die
+OKV="2.4.20"
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc -sparc -alpha -hppa -mips -arm"
+SLOT="${KV}"
+DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ # If the compiler isn't gcc3 drop the gcc3 patches
+ if [[ "${COMPILER}" == "gcc3" ]];then
+ einfo "You are using gcc3.x"
+ einfo "Enabling gcc>31 processor optimizations."
+ einfo "To use, choose the processor family labelled with (gcc>31) in"
+ einfo "Processor type and features -> Processor Family"
+ else
+ einfo "Your compiler is not gcc3, dropping patches..."
+ for file in *gcc3*;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ fi
+
+ # This is the ratified crypt USE flag, enables IPSEC & USAGI
+ if [ -z "`use crypt`" ]; then
+ einfo "No Cryptographic support, dropping patches..."
+ for file in 6* 7* 8* ;do
+ einfo "Dropping ${file}..."
+ rm -f ${file}
+ done
+ else
+ einfo "Cryptographic support enabled..."
+ fi
+
+ kernel_src_unpack
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ einfo "Please be warned, you have just installed a unstable"
+ einfo "patchset of the Gentoo Linux kernel sources."
+ einfo "This set contains the ptrace patch."
+ einfo "If there are issues with it, please report them"
+ einfo "by assigning bugs on bugs.gentoo.org to"
+ einfo "x86-kernel@gentoo.org"
+}