summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-01-31 04:59:18 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-01-31 04:59:18 +0000
commit0ee91d30bb7cdd76fbb880584e016f84836becc4 (patch)
treee6665a8d49fc8bbd703bde0ec35cc73f4e8dfb54 /sys-kernel
parentautotools isn't used (diff)
downloadgentoo-2-0ee91d30bb7cdd76fbb880584e016f84836becc4.tar.gz
gentoo-2-0ee91d30bb7cdd76fbb880584e016f84836becc4.tar.bz2
gentoo-2-0ee91d30bb7cdd76fbb880584e016f84836becc4.zip
Version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/zen-sources/ChangeLog9
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.31_p12.ebuild56
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.32_p6.ebuild52
3 files changed, 116 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index 1d4bf34d5f60..14da5478c7c2 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.27 2010/01/25 09:32:12 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.28 2010/01/31 04:59:18 hwoarang Exp $
+
+*zen-sources-2.6.32_p6 (31 Jan 2010)
+*zen-sources-2.6.31_p12 (31 Jan 2010)
+
+ 31 Jan 2010; <hwoarang@gentoo.org> +zen-sources-2.6.31_p12.ebuild,
+ +zen-sources-2.6.32_p6.ebuild:
+ Version bump
*zen-sources-2.6.33_rc5_p1 (25 Jan 2010)
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.31_p12.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.31_p12.ebuild
new file mode 100644
index 000000000000..c157626f0717
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.31_p12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+#no drm-next on this release
+#ZEN_DRM_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}-drmnext.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+#ZEN_DRM_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/custom/${ZEN_DRM_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+ use drm-next && epatch "${DISTDIR}"/"${ZEN_DRM_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.32_p6.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.32_p6.ebuild
new file mode 100644
index 000000000000..f6a1d94ae7bb
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.32_p6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"