summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-09-13 23:57:44 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-09-13 23:57:44 +0000
commit0c21101268f5aab666e9c8a593089d1b20689a8e (patch)
tree64e7171a491884d57c761ee11705a44b0207234d /sys-kernel
parentvanilla-3.2.62 + genpatches-3.2.16 + grsecurity-3.0-3.2.62-201409112233 (diff)
downloadgentoo-2-0c21101268f5aab666e9c8a593089d1b20689a8e.tar.gz
gentoo-2-0c21101268f5aab666e9c8a593089d1b20689a8e.tar.bz2
gentoo-2-0c21101268f5aab666e9c8a593089d1b20689a8e.zip
vanilla-3.14.18 + genpatches-3.14-22 + grsecurity-3.0-3.14.18-201409112236
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.14.18-r1.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index a36144e9528e..410cc85780b9 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1136 2014/09/13 23:56:08 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.1137 2014/09/13 23:57:44 blueness Exp $
+
+*hardened-sources-3.14.18-r1 (14 Sep 2014)
+
+ 14 Sep 2014; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.14.18-r1.ebuild:
+ vanilla-3.14.18 + genpatches-3.14-22 + grsecurity-3.0-3.14.18-201409112236
*hardened-sources-3.2.62-r6 (13 Sep 2014)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.14.18-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.14.18-r1.ebuild
new file mode 100644
index 000000000000..0f7fb864e525
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.14.18-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.14.18-r1.ebuild,v 1.1 2014/09/13 23:57:44 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base"
+K_GENPATCHES_VER="22"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="
+ 1500_XATTR_USER_PREFIX.patch
+ 2900_dev-root-proc-mount-fix.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}