summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-02-07 05:43:58 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-02-07 05:43:58 +0000
commit0898eb3f7ee330828d4d8843b49863d80c5d6ab1 (patch)
tree75447ff5072ea9c0dbd7b1af6fdd425b01a17d6a /sys-kernel
parentWhoops. Didn't add the ChangeLog. tada (diff)
downloadgentoo-2-0898eb3f7ee330828d4d8843b49863d80c5d6ab1.tar.gz
gentoo-2-0898eb3f7ee330828d4d8843b49863d80c5d6ab1.tar.bz2
gentoo-2-0898eb3f7ee330828d4d8843b49863d80c5d6ab1.zip
just doin what the man says
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/mjc-sources/files/digest-mjc-sources-2.5.59-r13
-rw-r--r--sys-kernel/mjc-sources/mjc-sources-2.5.59-r1.ebuild104
2 files changed, 107 insertions, 0 deletions
diff --git a/sys-kernel/mjc-sources/files/digest-mjc-sources-2.5.59-r1 b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.5.59-r1
new file mode 100644
index 000000000000..6d343e345f08
--- /dev/null
+++ b/sys-kernel/mjc-sources/files/digest-mjc-sources-2.5.59-r1
@@ -0,0 +1,3 @@
+MD5 f574000bfc8b602d0b618629ad3b001d linux-2.5.59.tar.bz2 31683004
+MD5 dfefad46bd968ffd2a76436dc66edff9 2.5.59-mm8.gz 580719
+MD5 b4b139f380184efb29ebb8bdbbaf0f05 anticipatory_io_scheduling.patch 24884
diff --git a/sys-kernel/mjc-sources/mjc-sources-2.5.59-r1.ebuild b/sys-kernel/mjc-sources/mjc-sources-2.5.59-r1.ebuild
new file mode 100644
index 000000000000..bf3e02419908
--- /dev/null
+++ b/sys-kernel/mjc-sources/mjc-sources-2.5.59-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mjc-sources/mjc-sources-2.5.59-r1.ebuild,v 1.1 2003/02/07 05:43:58 lostlogic Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR/r/mjc}
+EXTRAVERSION="-${PR/r/mjc}"
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# beta 2.5.59 kernel sources with the -mm patch and experimental stuff.
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.5/linux-${OKV}.tar.bz2
+http://www.zipworld.com.au/~akpm/linux/patches/2.5/${OKV}/${OKV}-mm8.gz
+http://www.zipworld.com.au/~akpm/linux/patches/2.5/${OKV}/${OKV}-mm8/experimental/anticipatory_io_scheduling.patch"
+
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="${KV}"
+KEYWORDS="x86 ppc"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl
+ sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+
+ mv linux-${OKV} linux-${KV}
+ cd ${S}
+ zcat ${DISTDIR}/${OKV}-mm8.gz | patch -p1 -l || \
+ die "akpm patch application failure"
+ cat ${DISTDIR}/anticipatory_io_scheduling.patch | patch -p1 || \
+ die "experimental patch application failure"
+ sed -e "s:^EXTRAVERSION.*$:EXTRAVERSION = ${EXTRAVERSION}:" \
+ Makefile > Makefile.new
+ mv Makefile.new Makefile
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux-beta ]
+ then
+
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux-beta
+ fi
+}