summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-02 10:29:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-02 10:29:19 +0000
commit0793cc785f82cc458399a6e80912019cbb9cdce9 (patch)
treec1bae0518844f18afc737c1db09206aacb5ee851 /sys-kernel/zen-sources
parentInitial commit of pecl-yaml (requested in #347511). Thanks to nathan for the ... (diff)
downloadgentoo-2-0793cc785f82cc458399a6e80912019cbb9cdce9.tar.gz
gentoo-2-0793cc785f82cc458399a6e80912019cbb9cdce9.tar.bz2
gentoo-2-0793cc785f82cc458399a6e80912019cbb9cdce9.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/zen-sources')
-rw-r--r--sys-kernel/zen-sources/ChangeLog8
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.36_p1.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index 44f3e2b6f095..cac087ea4400 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.45 2010/10/26 11:27:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.46 2010/12/02 10:29:19 hwoarang Exp $
+
+*zen-sources-2.6.36_p1 (02 Dec 2010)
+
+ 02 Dec 2010; Markos Chandras <hwoarang@gentoo.org>
+ +zen-sources-2.6.36_p1.ebuild:
+ Version bump
26 Oct 2010; Markos Chandras <hwoarang@gentoo.org>
-zen-sources-2.6.32_p6.ebuild, -zen-sources-2.6.32_p7.ebuild,
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.36_p1.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.36_p1.ebuild
new file mode 100644
index 000000000000..4a61f2a00b29
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.36_p1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-2.6.36_p1.ebuild,v 1.1 2010/12/02 10:29:19 hwoarang Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+RDEPEND=""
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"