summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Rickard <frogger@gentoo.org>2003-07-23 19:17:05 +0000
committerMatt Rickard <frogger@gentoo.org>2003-07-23 19:17:05 +0000
commitcf833f27c7ad51c31a5d5f2b3326f2f6f0971b44 (patch)
tree7fdb701e6b120366a6f9d52efff371eb3f4297ae /sys-kernel/vanilla-prepatch-sources
parentInitial import of vanilla-prepatch-sources (diff)
downloadgentoo-2-cf833f27c7ad51c31a5d5f2b3326f2f6f0971b44.tar.gz
gentoo-2-cf833f27c7ad51c31a5d5f2b3326f2f6f0971b44.tar.bz2
gentoo-2-cf833f27c7ad51c31a5d5f2b3326f2f6f0971b44.zip
Initial import of vanilla-prepatch-sources
Diffstat (limited to 'sys-kernel/vanilla-prepatch-sources')
-rw-r--r--sys-kernel/vanilla-prepatch-sources/ChangeLog11
-rw-r--r--sys-kernel/vanilla-prepatch-sources/Manifest3
-rw-r--r--sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre7.ebuild46
3 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/vanilla-prepatch-sources/ChangeLog b/sys-kernel/vanilla-prepatch-sources/ChangeLog
new file mode 100644
index 000000000000..4c86611b9bff
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-kernel/vanilla-prepatch-sources
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/ChangeLog,v 1.1 2003/07/23 19:16:36 frogger Exp $
+
+*vanilla-prepatch-sources-2.4.22_pre7 (23 Jul 2003)
+
+ 23 Jul 2003; Matthew Rickard <frogger@gentoo.org>
+ vanilla-prepatch-sources-2.4.22_pre7.ebuild:
+ New package for vanilla prerelease sources. Thanks
+ to Ian Abbott. This closes Bug #25107.
+
diff --git a/sys-kernel/vanilla-prepatch-sources/Manifest b/sys-kernel/vanilla-prepatch-sources/Manifest
index 6b7baaea5d4e..e2f585c2d604 100644
--- a/sys-kernel/vanilla-prepatch-sources/Manifest
+++ b/sys-kernel/vanilla-prepatch-sources/Manifest
@@ -1,2 +1,3 @@
-MD5 54ac179ad44c5ec13a86b3998eb8bd24 vanilla-prepatch-sources-2.4.22_pre7.ebuild 1333
+MD5 c0b832d8d5c0ae9d9a6ac9f8e2b4b73d vanilla-prepatch-sources-2.4.22_pre7.ebuild 1478
+MD5 241837d6a4bbf6189ca3a6d8984388bc ChangeLog 502
MD5 ae6ad96d78df15c03c62089437fbefcc files/digest-vanilla-prepatch-sources-2.4.22_pre7 134
diff --git a/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre7.ebuild b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre7.ebuild
new file mode 100644
index 000000000000..318ebbbf9ee1
--- /dev/null
+++ b/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/vanilla-prepatch-sources/vanilla-prepatch-sources-2.4.22_pre7.ebuild,v 1.1 2003/07/23 19:16:36 frogger Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.21"
+KV="${PV/_/-}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for the prerelease vanilla Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+
+ bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+
+ kernel_universal_unpack
+}
+
+pkg_postinst() {
+ einfo "Prepatches are the equivalent to alpha releases for Linux."
+ einfo "They may be poorly tested, and may not work at all."
+ einfo "Prepatches with -rc in the name are release candidates and"
+ einfo "may become full versions. It is particularly important"
+ einfo "that these are thoroughly tested and bugs are reported back"
+ einfo "upstream (and not to the Gentoo team)."
+}