summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-10-26 19:35:49 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-10-26 19:35:49 +0000
commitdaa0564b1f6662924784fd1a4b0b54e31527931c (patch)
tree32b277a28c9396b22cb5e190d46719527e401c50 /sys-kernel/tuxonice-sources
parentRemove old vulnerable versions (diff)
downloadgentoo-2-daa0564b1f6662924784fd1a4b0b54e31527931c.tar.gz
gentoo-2-daa0564b1f6662924784fd1a4b0b54e31527931c.tar.bz2
gentoo-2-daa0564b1f6662924784fd1a4b0b54e31527931c.zip
Version bump.
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog8
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 3337c64f23d4..1f1e451672ae 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.102 2010/10/22 17:22:50 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.103 2010/10/26 19:35:49 nelchael Exp $
+
+*tuxonice-sources-2.6.36 (26 Oct 2010)
+
+ 26 Oct 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.36.ebuild:
+ Version bump.
*tuxonice-sources-2.6.35-r6 (22 Oct 2010)
*tuxonice-sources-2.6.34-r8 (22 Oct 2010)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36.ebuild
new file mode 100644
index 000000000000..51370df0da6f
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36.ebuild,v 1.1 2010/10/26 19:35:49 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.36"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}