summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-11-04 10:09:55 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-11-04 10:09:55 +0000
commitc66a6f2ad7773b43ff1c66d00757a5e35c55dd47 (patch)
tree05143f9eb51cf2c3ce0466dd9dda81e2c5d1b4d3 /sys-kernel/tuxonice-sources
parentRevision bump for new genpatches. (diff)
downloadgentoo-2-c66a6f2ad7773b43ff1c66d00757a5e35c55dd47.tar.gz
gentoo-2-c66a6f2ad7773b43ff1c66d00757a5e35c55dd47.tar.bz2
gentoo-2-c66a6f2ad7773b43ff1c66d00757a5e35c55dd47.zip
Revision bump for new genpatches.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog9
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r20.ebuild47
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r7.ebuild48
3 files changed, 103 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index 1f1e451672ae..1077e0eae581 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.103 2010/10/26 19:35:49 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.104 2010/11/04 10:09:55 nelchael Exp $
+
+*tuxonice-sources-2.6.35-r7 (04 Nov 2010)
+*tuxonice-sources-2.6.32-r20 (04 Nov 2010)
+
+ 04 Nov 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.32-r20.ebuild, +tuxonice-sources-2.6.35-r7.ebuild:
+ Revision bump for new genpatches.
*tuxonice-sources-2.6.36 (26 Oct 2010)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r20.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r20.ebuild
new file mode 100644
index 000000000000..e9d7feeaff35
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r20.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r20.ebuild,v 1.1 2010/11/04 10:09:55 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="26"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.32"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ >=sys-power/hibernate-script-2.0"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r7.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r7.ebuild
new file mode 100644
index 000000000000..7a1dbc5e6e5c
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r7.ebuild,v 1.1 2010/11/04 10:09:55 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.35"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}