summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-08 12:11:20 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-08 12:11:20 +0000
commitab53e0f16ba566a3f5ffedc304e997df41ee368b (patch)
treef4db5d0f6cf077f402bba320f46fde769a639fcd /sys-kernel/tuxonice-sources
parentVersion bump. (diff)
downloadgentoo-2-ab53e0f16ba566a3f5ffedc304e997df41ee368b.tar.gz
gentoo-2-ab53e0f16ba566a3f5ffedc304e997df41ee368b.tar.bz2
gentoo-2-ab53e0f16ba566a3f5ffedc304e997df41ee368b.zip
Version bump.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog8
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.0.36.ebuild46
2 files changed, 52 insertions, 2 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index e00f6e786dba..356fe796b9a1 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.143 2012/06/24 22:01:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.144 2012/07/08 12:11:20 pacho Exp $
+
+*tuxonice-sources-3.0.36 (08 Jul 2012)
+
+ 08 Jul 2012; Pacho Ramos <pacho@gentoo.org> +tuxonice-sources-3.0.36.ebuild:
+ Version bump.
24 Jun 2012; Agostino Sarubbo <ago@gentoo.org>
tuxonice-sources-3.0.35.ebuild:
@@ -1608,4 +1613,3 @@
+files/linux-2.6.12-vesafb-tng-suspend2.patch, +metadata.xml,
+suspend2-sources-2.6.12.ebuild:
Initial import.
-
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.36.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.36.ebuild
new file mode 100644
index 000000000000..a595b0db9e9f
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.36.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.0.36.ebuild,v 1.1 2012/07/08 12:11:20 pacho Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="27"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT="20111012"
+TUXONICE_VERSION=""
+TUXONICE_TARGET="3.0"
+
+# Because "current" patches can change without notifying, we need to supply them
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="http://dev.gentoo.org/~pacho/tuxonice/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch"
+ UNIPATCH_LIST="${DISTDIR}/current-tuxonice-for-${TUXONICE_TARGET}_${TUXONICE_SNAPSHOT}.patch.bz2"
+else
+ TUXONICE_SRC="http://www.tuxonice.net/files/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+ UNIPATCH_LIST="${DISTDIR}/tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch.bz2"
+fi
+
+TUXONICE_URI="${TUXONICE_SRC}.bz2"
+
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"