summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-12-12 10:47:38 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-12-12 10:47:38 +0000
commit695f33460da0c9529de45e3e429e235caca92897 (patch)
treeed0d7d744bbf3aa9fa71c64fba35ccef1dccc081 /sys-kernel/tuxonice-sources
parentx86 stable per bug 348197 (diff)
downloadgentoo-2-695f33460da0c9529de45e3e429e235caca92897.tar.gz
gentoo-2-695f33460da0c9529de45e3e429e235caca92897.tar.bz2
gentoo-2-695f33460da0c9529de45e3e429e235caca92897.zip
Revision bumps for new genpatches.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/tuxonice-sources')
-rw-r--r--sys-kernel/tuxonice-sources/ChangeLog11
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r22.ebuild47
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r9.ebuild48
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36-r3.ebuild48
4 files changed, 153 insertions, 1 deletions
diff --git a/sys-kernel/tuxonice-sources/ChangeLog b/sys-kernel/tuxonice-sources/ChangeLog
index e7091e73337e..34a00ef2c9bf 100644
--- a/sys-kernel/tuxonice-sources/ChangeLog
+++ b/sys-kernel/tuxonice-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-kernel/tuxonice-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.107 2010/11/23 00:46:58 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/ChangeLog,v 1.108 2010/12/12 10:47:38 nelchael Exp $
+
+*tuxonice-sources-2.6.36-r3 (12 Dec 2010)
+*tuxonice-sources-2.6.35-r9 (12 Dec 2010)
+*tuxonice-sources-2.6.32-r22 (12 Dec 2010)
+
+ 12 Dec 2010; Krzysztof Pawlik <nelchael@gentoo.org>
+ +tuxonice-sources-2.6.32-r22.ebuild, +tuxonice-sources-2.6.35-r9.ebuild,
+ +tuxonice-sources-2.6.36-r3.ebuild:
+ Revision bumps for new genpatches.
*tuxonice-sources-2.6.35-r8 (23 Nov 2010)
*tuxonice-sources-2.6.32-r21 (23 Nov 2010)
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r22.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r22.ebuild
new file mode 100644
index 000000000000..75356e58f860
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r22.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.32-r22.ebuild,v 1.1 2010/12/12 10:47:38 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="29"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.32"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ >=sys-power/hibernate-script-2.0"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r9.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r9.ebuild
new file mode 100644
index 000000000000..de44a739b37b
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.35-r9.ebuild,v 1.1 2010/12/12 10:47:38 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="15"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.35"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36-r3.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36-r3.ebuild
new file mode 100644
index 000000000000..c432d256978a
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-2.6.36-r3.ebuild,v 1.1 2010/12/12 10:47:38 nelchael Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+IUSE=""
+
+TUXONICE_SNAPSHOT=""
+TUXONICE_VERSION="3.2-rc2"
+TUXONICE_TARGET="2.6.36"
+
+if [[ -n "${TUXONICE_SNAPSHOT}" ]]; then
+ TUXONICE_SRC="current-tuxonice-for-${TUXONICE_TARGET}.patch-${TUXONICE_SNAPSHOT}"
+else
+ TUXONICE_SRC="tuxonice-${TUXONICE_VERSION}-for-${TUXONICE_TARGET}.patch"
+fi
+
+TUXONICE_URI="http://www.tuxonice.net/files/${TUXONICE_SRC}.bz2"
+
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_SRC}.bz2"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}