summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-01-23 12:54:51 +0000
committerChristian Birchinger <joker@gentoo.org>2003-01-23 12:54:51 +0000
commitd6f5a72245d2294d4c72c7c24008552ed87acc95 (patch)
treea96b51237c744deda012f9a287848298f4e8d163 /sys-kernel/sparc-sources
parentFixed deps (diff)
downloadgentoo-2-d6f5a72245d2294d4c72c7c24008552ed87acc95.tar.gz
gentoo-2-d6f5a72245d2294d4c72c7c24008552ed87acc95.tar.bz2
gentoo-2-d6f5a72245d2294d4c72c7c24008552ed87acc95.zip
Removed sparc-sources-2.4.21_pre1
Diffstat (limited to 'sys-kernel/sparc-sources')
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.21_pre13
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.21_pre1.ebuild119
2 files changed, 0 insertions, 122 deletions
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.21_pre1 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.21_pre1
deleted file mode 100644
index 4fed25b40ec0..000000000000
--- a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.21_pre1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
-MD5 c73ae3cb3fdadc13b54445eabbb326ee patch-2.4.21-pre1.gz 1101142
-MD5 9661ed5ec3900e0a4b8297813cd303c8 patches-2.4.21-pre1-sparc.tar.bz2 45529
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.21_pre1.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.21_pre1.ebuild
deleted file mode 100644
index c29f3169be1c..000000000000
--- a/sys-kernel/sparc-sources/sparc-sources-2.4.21_pre1.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.21_pre1.ebuild,v 1.3 2002/12/20 03:16:51 seemant Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-IUSE="build"
-
-#we use this next variable to avoid duplicating stuff on cvs
-OKV=2.4.20
-MY_PVR=${PVR/_/-}
-[ "${PR}" == "r0" ] && KV=${MY_PVR}-sparc || KV=${PV}-sparc-${PR}
-EXTRAVERSION="`echo ${KV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\):\1:'`"
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-#Documentation on the patches contained in this kernel will be installed
-#to /usr/share/doc/sparc-sources-${PVR}/patches.txt.gz
-
-DESCRIPTION="Full sources for the Gentoo Linux kernel for Sparc64"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${MY_PVR}.gz
- mirror://gentoo/patches-${MY_PVR}-sparc.tar.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="~x86 -ppc ~sparc -alpha"
-
-if [ $ETYPE = "sources" ]
-then
- DEPEND="!build? ( >=sys-devel/binutils-2.11.90.0.31 )"
- RDEPEND="${RDEPEND}
- !build? ( >=sys-libs/ncurses-5.2
- sys-devel/perl
- >=sys-apps/modutils-2.4.2
- sys-devel/make )"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -Os -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- unpack ${A}
- mv linux-${OKV} linux-${KV} || die
-
- # patch the kernel to the latest sources
- cd ${S}
- patch -p1 < ${WORKDIR}/patch-${MY_PVR} || die
-
- # Now we need to deal with the tarball of patches.
- cd ${WORKDIR}/${KV} || die "No patch dir to change to"
- ./addpatches . ${WORKDIR}/linux-${KV} || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- cd ${S}
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- # also fix the EXTRAVERSION
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make distclean || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "sources" ]
- then
- dodir /usr/src
- echo ">>> Copying sources..."
- cat ${WORKDIR}/${KV}/docs/* > patches.txt
- dodoc patches.txt
- mv ${WORKDIR}/linux* ${D}/usr/src
- else
- #linux-headers
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- rm -rf ${D}/usr/include/linux/modules
- dodir /usr/include/asm
- use x86 && cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- use sparc && cp -ax ${S}/include/asm-sparc/* ${D}/usr/include/asm
- use && cp -ax ${S}/include/asm-/* ${D}/usr/include/asm
- fi
-
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- rm -f ${ROOT}usr/src/linux
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
- fi
-}