summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2007-01-16 14:17:12 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2007-01-16 14:17:12 +0000
commit0acd838651121708034bd2657c0d68f6978d9278 (patch)
tree02292fa25a9f5b33c1727f3b5f4fbdccac902ab7 /sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-0acd838651121708034bd2657c0d68f6978d9278.tar.gz
gentoo-2-0acd838651121708034bd2657c0d68f6978d9278.tar.bz2
gentoo-2-0acd838651121708034bd2657c0d68f6978d9278.zip
New for 2007
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild')
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild
new file mode 100644
index 000000000000..1bb86f87b5ba
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.34.ebuild,v 1.1 2007/01/16 14:17:12 gustavoz Exp $
+
+ETYPE="sources"
+IUSE="ultra1"
+inherit kernel-2
+detect_version
+
+PATCH_BASE="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}${EXTRAVERSION}"
+
+SSV_URI="mirror://gentoo/patches-${PATCH_BASE}.tar.bz2"
+
+KEYWORDS="-* ~sparc"
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+UNIPATCH_LIST="${DISTDIR}/patches-${PATCH_BASE}.tar.bz2"
+SRC_URI="${KERNEL_URI} ${SSV_URI}"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org"
+
+pkg_setup() {
+ use ultra1 || UNIPATCH_EXCLUDE="${UNIPATCH_EXCLUDE} 2000_U1-hme-lockup.patch"
+}
+
+pkg_postinst() {
+ postinst_sources
+
+ if [ ! -r "/proc/openprom/name" -o "cat /proc/openprom/name 2>/dev/null" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+
+}