summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-12-26 23:43:10 +0000
committerMichael Weber <xmw@gentoo.org>2013-12-26 23:43:10 +0000
commit55df6acb3f8397526d0880931c9cfda293d6f015 (patch)
treed9a8ce0b5e8b2388f05b02ec1501ed71b36966a4 /sys-kernel/raspberrypi-sources
parentAdd epatch_user call to make patch testing easier. (diff)
downloadgentoo-2-55df6acb3f8397526d0880931c9cfda293d6f015.tar.gz
gentoo-2-55df6acb3f8397526d0880931c9cfda293d6f015.tar.bz2
gentoo-2-55df6acb3f8397526d0880931c9cfda293d6f015.zip
Add 3.12 slot
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/ChangeLog8
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/sys-kernel/raspberrypi-sources/ChangeLog b/sys-kernel/raspberrypi-sources/ChangeLog
index 4089acf8e571..1e31c0b23283 100644
--- a/sys-kernel/raspberrypi-sources/ChangeLog
+++ b/sys-kernel/raspberrypi-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/raspberrypi-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/raspberrypi-sources/ChangeLog,v 1.4 2013/09/09 18:47:18 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/raspberrypi-sources/ChangeLog,v 1.5 2013/12/26 23:43:10 xmw Exp $
+
+*raspberrypi-sources-3.12.9999 (26 Dec 2013)
+
+ 26 Dec 2013; Michael Weber <xmw@gentoo.org>
+ +raspberrypi-sources-3.12.9999.ebuild:
+ Add 3.12 slot
*raspberrypi-sources-3.11.9999 (09 Sep 2013)
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
new file mode 100644
index 000000000000..a410af0cfb90
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/raspberrypi-sources/raspberrypi-sources-3.12.9999.ebuild,v 1.1 2013/12/26 23:43:10 xmw Exp $
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}