summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-03-31 04:02:16 +0000
committerTom Gall <tgall@gentoo.org>2004-03-31 04:02:16 +0000
commit3b10a83e00b2e1fbb58a626336d3d722fd7ba775 (patch)
tree17858131e8409f354070106cecebc39cd30f66f2 /sys-kernel/ppc64-headers
parentvirtual/x11; depend on sed >= 4; error check sed (Manifest recommit) (diff)
downloadgentoo-2-3b10a83e00b2e1fbb58a626336d3d722fd7ba775.tar.gz
gentoo-2-3b10a83e00b2e1fbb58a626336d3d722fd7ba775.tar.bz2
gentoo-2-3b10a83e00b2e1fbb58a626336d3d722fd7ba775.zip
ppc64 headers for glibc builds and anything that needs it
Diffstat (limited to 'sys-kernel/ppc64-headers')
-rw-r--r--sys-kernel/ppc64-headers/ChangeLog9
-rw-r--r--sys-kernel/ppc64-headers/files/digest-ppc64-headers-2.6.42
-rw-r--r--sys-kernel/ppc64-headers/ppc64-headers-2.6.4.ebuild84
3 files changed, 95 insertions, 0 deletions
diff --git a/sys-kernel/ppc64-headers/ChangeLog b/sys-kernel/ppc64-headers/ChangeLog
new file mode 100644
index 000000000000..8b4c5852d25c
--- /dev/null
+++ b/sys-kernel/ppc64-headers/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-kernel/ppc64-headers
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc64-headers/ChangeLog,v 1.1 2004/03/31 04:02:16 tgall Exp $
+
+*ppc64-headers-2.6.4.ebuild (30 Mar 2004)
+
+ 10 Feb 2004; tgall <tgall@gentoo.org> ppc64-headers-2.6.4.ebuild:
+ ppc64 kernel headers for 2.6 based kernels
+
diff --git a/sys-kernel/ppc64-headers/files/digest-ppc64-headers-2.6.4 b/sys-kernel/ppc64-headers/files/digest-ppc64-headers-2.6.4
new file mode 100644
index 000000000000..81ba3e6e4bcd
--- /dev/null
+++ b/sys-kernel/ppc64-headers/files/digest-ppc64-headers-2.6.4
@@ -0,0 +1,2 @@
+MD5 335f06eba1e5372ba38a0d2b253629bd linux-2.6.4.tar.bz2 34386912
+MD5 a03b1dec0f64b066ee458d00b29e90f2 ppc64-ames264.patch.gz 353568
diff --git a/sys-kernel/ppc64-headers/ppc64-headers-2.6.4.ebuild b/sys-kernel/ppc64-headers/ppc64-headers-2.6.4.ebuild
new file mode 100644
index 000000000000..c93ac382583d
--- /dev/null
+++ b/sys-kernel/ppc64-headers/ppc64-headers-2.6.4.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc64-headers/ppc64-headers-2.6.4.ebuild,v 1.1 2004/03/31 04:02:16 tgall Exp $
+
+IUSE="build crypt"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="headers"
+
+inherit kernel
+OKV="`echo ${PV}|sed -e 's:^\([0-9]\+\.[0-9]\+\.[0-9]\+\).*:\1:'`"
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}"
+OKV="2.6.4"
+
+S=${WORKDIR}/linux-${KV}
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/gentoo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Kernel."
+SRC_URI="mirror://kernel/linux/kernel/v2.6/linux-${OKV}.tar.bz2
+ mirror://kernel/ppc64-ames264.patch.gz"
+
+HOMEPAGE="http://www.gentoo.org/ http://www.kernel.org/"
+PROVIDE="virtual/kernel virtual/os-headers"
+LICENSE="GPL-2"
+KEYWORDS="-x86 -ppc -sparc -alpha -hppa -mips -arm ppc64"
+SLOT="${KV}"
+
+
+src_unpack() {
+ unpack ${A}
+# mv linux linux-${KV} || die "Error moving kernel source tree to
+# linux-${KV}"
+
+ cd ${WORKDIR}/linux-2.6.4
+
+ kernel_universal_unpack
+ cd ${WORKDIR}/linux-2.6.4
+ epatch ${WORKDIR}/ppc64-ames264.patch
+}
+
+src_install() {
+ if [ "`KV_to_int ${OKV}`" -ge "`KV_to_int 2.6.0`" ]; then
+ ln -sf ${S}/include/asm-${ARCH} ${S}/include/asm
+ fi
+
+
+ # Do normal src_install stuff
+ kernel_src_install
+
+ # If this is 2.5 or 2.6 headers, then we need asm-generic too
+ if [ "`KV_to_int ${OKV}`" -ge "`KV_to_int 2.6.0`" ]; then
+ dodir /usr/include/asm-generic
+ cp -ax ${S}/include/asm-generic/* ${D}/usr/include/asm-generic
+ fi
+
+}
+
+pkg_preinst() {
+ kernel_pkg_preinst
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ ewarn "There is no xfs support in this kernel."
+ echo
+ ewarn "If iptables/netfilter behaves abnormally, such as 'Invalid Argument',"
+ ewarn "you will need to re-emerge iptables to restore proper functionality."
+}