summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-05-01 14:08:35 +0000
committerDavid Holm <dholm@gentoo.org>2004-05-01 14:08:35 +0000
commitcc7a9be073814e918fb378049cbf55d15214e875 (patch)
tree19531db4cbf3c1d70a6c21ef3e28207a5743dbf3 /sys-kernel/ppc-sources
parentRemoved old kernels (Manifest recommit) (diff)
downloadgentoo-2-cc7a9be073814e918fb378049cbf55d15214e875.tar.gz
gentoo-2-cc7a9be073814e918fb378049cbf55d15214e875.tar.bz2
gentoo-2-cc7a9be073814e918fb378049cbf55d15214e875.zip
Removed old kernels
Diffstat (limited to 'sys-kernel/ppc-sources')
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild117
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.24-r1.ebuild73
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.24-r2.ebuild83
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.24-r3.ebuild82
-rw-r--r--sys-kernel/ppc-sources/ppc-sources-2.4.24.ebuild72
5 files changed, 0 insertions, 427 deletions
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild
deleted file mode 100644
index 921b843203a7..000000000000
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.19.ebuild,v 1.19 2004/02/22 23:32:31 agriffis Exp $
-
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=2.4.18
-KV=${PVR}
-S=${WORKDIR}/linux-${KV}
-ETYPE="sources"
-
-# What's in this kernel?
-
-# INCLUDED:
-# 2.4.19-pre6-ben0
-# Selected pre6aa1 patches:
-# 00_lowlatency-fixes-5
-# 70_xfs-8
-# 71_xfs-kiobuf-slab-1
-# 72_xfs-O_DIRECT-1
-# Ani Joshi's rivafb bigendian fixes from YDL
-
-
-DESCRIPTION="Full sources for the Gentoo Linux PPC kernel"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://ftp.sunsite.dk/projects/gentooppc/distfiles/linux-gentoo-ppc-${KV}.patch.bz2"
-PROVIDE="virtual/linux-sources"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
-LICENSE="GPL-2"
-SLOT="${KV}"
-KEYWORDS="ppc -x86 -sparc -alpha"
-
-XFSV=20020124
-
-if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31"
- RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-fi
-
-GENTOOPATCH=${DISTDIR}/linux-gentoo-ppc-${KV}.patch.bz2
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux linux-${KV} || die
- cd ${S}
- pwd
- bzcat ${GENTOOPATCH} | patch -p1 || die # Patch the kernel
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #this file is required for other things to build properly, so we autogenerate it
- make include/linux/version.h || die
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0:0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-}
-
-src_compile() {
- if [ "$ETYPE" = "headers" ]
- then
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- fi
-}
-
-src_install() {
- if [ "$ETYPE" = "linux-sources" ]
- then
- dodir /usr/src
- cd ${S}
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
- else
- #linux-headers
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
- make dep
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-ppc/* ${D}/usr/include/asm
- fi
-}
-
-pkg_preinst() {
- if [ "$ETYPE" = "headers" ]
- then
- [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
- [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
- true
- fi
-}
-
-pkg_postinst() {
- [ "$ETYPE" = "headers" ] && return
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- rm -f ${ROOT}usr/src/linux
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
- fi
-}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r1.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.24-r1.ebuild
deleted file mode 100644
index aed6c3779874..000000000000
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.24-r1.ebuild,v 1.1 2004/02/19 09:44:38 plasmaroo Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-ETYPE="sources"
-inherit kernel
-
-OKV="2.4.24"
-
-EXTRAVERSION="`echo ${PV}-benh0-${PR} | \
- sed -e 's/[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\)/\1/'`"
-
-KV=${PV}-benh0-${PR}
-AV=${PV}-benh0
-S=${WORKDIR}/linux-${KV}
-
-inherit eutils
-
-
-DESCRIPTION="Full sources for the linux kernel 2.4.24 with benh's patchset"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patch-${AV}.bz2
- http://dev.gentoo.org/~trance/stuff/patch-${AV}.bz2"
-
-KEYWORDS="ppc -ppc64"
-DEPEND=">=sys-devel/binutils-2.11.90.0.31"
-RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-
-SLOT=${KV}
-PROVIDE="virtual/linux-sources"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-
- mv linux-${OKV} ${PF}
- cd ${PF}
- epatch ${FILESDIR}/${P}.munmap.patch || die "Failed to apply munmap patch!"
- bzcat ${DISTDIR}/patch-${AV}.bz2 | patch -p1 || die "patch failed"
- find . -iname "*~" | xargs rm 2> /dev/null
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- # also fix the EXTRAVERSION
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-
- cd ${WORKDIR}/${PF}
- MY_ARCH=${ARCH}
- unset ARCH
-
- # Sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die "make mrproper died"
- ARCH=${MY_ARCH}
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
-}
-pkg_postinst() {
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- ln -sf ${PF} ${ROOT}/usr/src/linux
- fi
-
- ewarn "XFS file system support is not included in this kernel"
- echo
-}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r2.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.24-r2.ebuild
deleted file mode 100644
index fefa10b82e1a..000000000000
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.24-r2.ebuild,v 1.2 2004/04/12 16:36:23 aliz Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-# Included patches:
-# benh 2.4.24-0
-# pegasos 2.4.24-2
-# orinoco monitor 0.13
-# O_STREAMING 2.4.20-pre9-1
-# GRSecurity 2.0-rc4
-# ea+acl+nfsacl 0.8.65
-# XFS 2.4.23
-# Loop-Jari 2.4.22.0
-# FreeS/WAN 2.01
-# x509 1.4.5
-# Extra bootlogos
-# pmac_pmu fix, see bug #41668
-# munmap fix, see bug #42024
-
-ETYPE="sources"
-inherit kernel
-IUSE=""
-
-OKV="2.4.24"
-
-EXTRAVERSION="`echo ${PV}-${PN/-sources/}-${PR} | \
- sed -e 's/[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\)/\1/'`"
-
-KV=${PV}-${PN/-sources/}-${PR}
-S=${WORKDIR}/linux-${KV}
-
-inherit eutils
-
-
-DESCRIPTION="Full sources for the linux kernel 2.4.24 with benh's patchset"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patch-${KV}.bz2"
-
-KEYWORDS="ppc -ppc64"
-DEPEND=">=sys-devel/binutils-2.11.90.0.31"
-RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-
-SLOT=${KV}
-PROVIDE="virtual/linux-sources"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-
- mv linux-${OKV} ${PF}
- cd ${PF}
- bzcat ${DISTDIR}/patch-${KV}.bz2 | patch -p1 || die "patch failed"
- find . -iname "*~" | xargs rm 2> /dev/null
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- # also fix the EXTRAVERSION
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-
- cd ${WORKDIR}/${PF}
- MY_ARCH=${ARCH}
- unset ARCH
-
- # Sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die "make mrproper died"
- ARCH=${MY_ARCH}
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
-}
-pkg_postinst() {
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- ln -sf ${PF} ${ROOT}/usr/src/linux
- fi
-}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r3.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.24-r3.ebuild
deleted file mode 100644
index 980c55ccd0c6..000000000000
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.24-r3.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.24-r3.ebuild,v 1.1 2004/04/15 10:52:30 plasmaroo Exp $
-
-# Included patches:
-# benh 2.4.24-0
-# pegasos 2.4.24-2
-# orinoco monitor 0.13
-# O_STREAMING 2.4.20-pre9-1
-# GRSecurity 2.0-rc4
-# ea+acl+nfsacl 0.8.65
-# XFS 2.4.23
-# Loop-Jari 2.4.22.0
-# FreeS/WAN 2.01
-# x509 1.4.5
-# Extra bootlogos
-# pmac_pmu fix, see bug #41668
-# munmap fix, see bug #42024
-
-ETYPE="sources"
-inherit kernel
-IUSE=""
-
-OKV="2.4.24"
-
-EXTRAVERSION="`echo ${PV}-${PN/-sources/}-${PR} | \
- sed -e 's/[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\)/\1/'`"
-
-KV=${PV}-${PN/-sources/}-${PR}
-S=${WORKDIR}/linux-${KV}
-
-inherit eutils
-
-DESCRIPTION="Full sources for the linux kernel 2.4.24 with benh's patchset"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patch-${KV/r3/r2}.bz2"
-
-KEYWORDS="ppc -ppc64"
-DEPEND=">=sys-devel/binutils-2.11.90.0.31"
-RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-
-SLOT=${KV}
-PROVIDE="virtual/linux-sources"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-
- mv linux-${OKV} ${PF}
- cd ${PF}
- bzcat ${DISTDIR}/patch-${KV/r3/r2}.bz2 | patch -p1 || die "Patching failed!"
- epatch ${FILESDIR}/${P}.CAN-2004-0109.patch || die "Failed to patch CAN-2004-0109 vulnerability!"
- find . -iname "*~" | xargs rm 2> /dev/null
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- # also fix the EXTRAVERSION
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-
- cd ${WORKDIR}/${PF}
- MY_ARCH=${ARCH}
- unset ARCH
-
- # Sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die "make mrproper died"
- ARCH=${MY_ARCH}
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
-}
-pkg_postinst() {
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- ln -sf ${PF} ${ROOT}/usr/src/linux
- fi
-}
diff --git a/sys-kernel/ppc-sources/ppc-sources-2.4.24.ebuild b/sys-kernel/ppc-sources/ppc-sources-2.4.24.ebuild
deleted file mode 100644
index 0731737ace2e..000000000000
--- a/sys-kernel/ppc-sources/ppc-sources-2.4.24.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ppc-sources/ppc-sources-2.4.24.ebuild,v 1.4 2004/02/19 09:44:38 plasmaroo Exp $
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-ETYPE="sources"
-inherit kernel
-
-OKV="2.4.24"
-
-EXTRAVERSION="`echo ${PV}-${PR/r/benh} | \
- sed -e 's/[0-9]\+\.[0-9]\+\.[0-9]\+\(.*\)/\1/'`"
-
-KV=${PV}-${PR/r/benh}
-
-S=${WORKDIR}/linux-${KV}
-
-inherit eutils
-
-
-DESCRIPTION="Full sources for the linux kernel 2.4.24 with benh's patchset"
-SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- mirror://gentoo/patch-${KV}.bz2
- http://dev.gentoo.org/~trance/stuff/patch-${KV}.bz2"
-
-KEYWORDS="ppc -ppc64"
-DEPEND=">=sys-devel/binutils-2.11.90.0.31"
-RDEPEND=">=sys-libs/ncurses-5.2 dev-lang/perl virtual/modutils sys-devel/make"
-
-SLOT=${KV}
-PROVIDE="virtual/linux-sources"
-
-src_unpack() {
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
-
- mv linux-${OKV} ${PF}
- cd ${PF}
- bzcat ${DISTDIR}/patch-${KV}.bz2 | patch -p1 || die "patch failed"
- find . -iname "*~" | xargs rm 2> /dev/null
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- # also fix the EXTRAVERSION
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-
- cd ${WORKDIR}/${PF}
- MY_ARCH=${ARCH}
- unset ARCH
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die "make mrproper died"
- ARCH=${MY_ARCH}
-
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/* ${D}/usr/src
-}
-pkg_postinst() {
- if [ ! -e ${ROOT}usr/src/linux ]
- then
- ln -sf ${PF} ${ROOT}/usr/src/linux
- fi
-
- ewarn "XFS file system support is not included in this kernel"
- echo
-}