summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-05 18:46:09 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-05 18:46:09 +0000
commitd9a7279dd51a295701d6bd24c6ee50ce10656e65 (patch)
tree1bdfff57bcb499cc4655b5d153623a37c42592d6 /sys-kernel/pf-sources
parentUse.mask gtsk, devil, bug #419621 (diff)
downloadgentoo-2-d9a7279dd51a295701d6bd24c6ee50ce10656e65.tar.gz
gentoo-2-d9a7279dd51a295701d6bd24c6ee50ce10656e65.tar.bz2
gentoo-2-d9a7279dd51a295701d6bd24c6ee50ce10656e65.zip
Version bump
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.5.1.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index dce5e49643b3..ae546176adc3 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.69 2012/07/24 20:58:08 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.70 2012/08/05 18:46:09 hwoarang Exp $
+
+*pf-sources-3.5.1 (05 Aug 2012)
+
+ 05 Aug 2012; Markos Chandras <hwoarang@gentoo.org> +pf-sources-3.5.1.ebuild:
+ Version bump
24 Jul 2012; Markos Chandras <hwoarang@gentoo.org> -pf-sources-3.4.1.ebuild,
-pf-sources-3.4.2.ebuild, -pf-sources-3.4.3.ebuild, -pf-sources-3.4.4.ebuild,
diff --git a/sys-kernel/pf-sources/pf-sources-3.5.1.ebuild b/sys-kernel/pf-sources/pf-sources-3.5.1.ebuild
new file mode 100644
index 000000000000..44bbbfabed53
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.5.1.ebuild,v 1.1 2012/08/05 18:46:09 hwoarang Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog
+ elog "${P} has the following optional runtime dependencies:"
+ elog " sys-apps/tuxonice-userui"
+ elog " provides minimal userspace progress information related to"
+ elog " suspending and resuming process"
+ elog " sys-power/hibernate-script or sys-power/pm-utils"
+ elog " runtime utilites for hibernating and suspending your computer"
+ elog
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."