summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-11-24 08:53:54 +0000
committerAlex Alexander <wired@gentoo.org>2010-11-24 08:53:54 +0000
commitc8a53249d390487840a9d555d85a72afbb368a27 (patch)
tree1d702f3f809792ce62cd7db58996f27fb78c603a /sys-kernel/pf-sources
parentMarked ~ppc-macos (diff)
downloadgentoo-2-c8a53249d390487840a9d555d85a72afbb368a27.tar.gz
gentoo-2-c8a53249d390487840a9d555d85a72afbb368a27.tar.bz2
gentoo-2-c8a53249d390487840a9d555d85a72afbb368a27.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.36_p2.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 2aa7206542b7..f006a5a8b0d2 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.8 2010/11/19 17:11:28 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.9 2010/11/24 08:53:54 wired Exp $
+
+*pf-sources-2.6.36_p2 (24 Nov 2010)
+
+ 24 Nov 2010; Alex Alexander <wired@gentoo.org> +pf-sources-2.6.36_p2.ebuild:
+ version bump
19 Nov 2010; Alex Alexander <wired@gentoo.org> pf-sources-2.6.36_p1.ebuild,
metadata.xml:
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.36_p2.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.36_p2.ebuild
new file mode 100644
index 000000000000..6ee1fbd3d4d5
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.36_p2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.36_p2.ebuild,v 1.1 2010/11/24 08:53:54 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI} ${EXPERIMENTAL_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="experimental"
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+ if use experimental; then
+ for patch in ${EXPERIMENTAL_PATCHES[@]}; do
+ epatch "${DISTDIR}"/"${patch/*\/}"
+ done
+ fi
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."