summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-09-28 15:35:38 +0000
committerAlex Alexander <wired@gentoo.org>2010-09-28 15:35:38 +0000
commit11c5385fd116732105272d35e5c5d8a7b66bf4b5 (patch)
treefc8b082d29116717e653928e42bf0ade55bce9c9 /sys-kernel/pf-sources
parentstable ppc, bug 333193 (diff)
downloadgentoo-2-11c5385fd116732105272d35e5c5d8a7b66bf4b5.tar.gz
gentoo-2-11c5385fd116732105272d35e5c5d8a7b66bf4b5.tar.bz2
gentoo-2-11c5385fd116732105272d35e5c5d8a7b66bf4b5.zip
version bump
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/ChangeLog8
-rw-r--r--sys-kernel/pf-sources/pf-sources-2.6.35_p10.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 04e617ae4e7b..38fd05a2a081 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.4 2010/09/23 16:34:40 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.5 2010/09/28 15:35:38 wired Exp $
+
+*pf-sources-2.6.35_p10 (28 Sep 2010)
+
+ 28 Sep 2010; Alex Alexander <wired@gentoo.org>
+ +pf-sources-2.6.35_p10.ebuild:
+ version bump
*pf-sources-2.6.35_p8 (23 Sep 2010)
diff --git a/sys-kernel/pf-sources/pf-sources-2.6.35_p10.ebuild b/sys-kernel/pf-sources/pf-sources-2.6.35_p10.ebuild
new file mode 100644
index 000000000000..0275910d52c9
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-2.6.35_p10.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-2.6.35_p10.ebuild,v 1.1 2010/09/28 15:35:38 wired Exp $
+
+EAPI="2"
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf-kernel.org.ua/"
+
+PF_PATCHSET="${PV/*_p}"
+PF_KERNEL="${PV/_p[0-9]*}"
+PF_KERNEL="${PF_KERNEL/_/-}"
+PF_FILE="patch-${PF_KERNEL}-pf${PF_PATCHSET}${COMPRESSTYPE}"
+PF_URI="http://pf-kernel.org.ua/sources/$(get_version_component_range 1-3)/${PF_FILE}"
+SRC_URI="${KERNEL_URI} ${PF_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+KV_FULL="${PVR/_p/-pf}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."