summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-11-09 13:55:32 +0000
committerPeter Volkov <pva@gentoo.org>2010-11-09 13:55:32 +0000
commitbf83470958bf5cf3e780ed16ec98b934aee010c6 (patch)
tree265d0749d48ae6653d06281c8fc1bd915b34b172 /sys-kernel/openvz-sources
parentVersion bump #343719 by Rodrigo Severo. (diff)
downloadgentoo-2-bf83470958bf5cf3e780ed16ec98b934aee010c6.tar.gz
gentoo-2-bf83470958bf5cf3e780ed16ec98b934aee010c6.tar.bz2
gentoo-2-bf83470958bf5cf3e780ed16ec98b934aee010c6.zip
Version bump.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/openvz-sources')
-rw-r--r--sys-kernel/openvz-sources/ChangeLog10
-rw-r--r--sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-cpt_process.c-build.patch36
-rw-r--r--sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-orphans.patch107
-rw-r--r--sys-kernel/openvz-sources/openvz-sources-2.6.32.10.1.ebuild56
4 files changed, 208 insertions, 1 deletions
diff --git a/sys-kernel/openvz-sources/ChangeLog b/sys-kernel/openvz-sources/ChangeLog
index 6a0f608f5c33..bc14dc5064fb 100644
--- a/sys-kernel/openvz-sources/ChangeLog
+++ b/sys-kernel/openvz-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/openvz-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/ChangeLog,v 1.153 2010/10/25 13:56:15 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/ChangeLog,v 1.154 2010/11/09 13:55:32 pva Exp $
+
+*openvz-sources-2.6.32.10.1 (09 Nov 2010)
+
+ 09 Nov 2010; Peter Volkov <pva@gentoo.org>
+ +openvz-sources-2.6.32.10.1.ebuild,
+ +files/openvz-sources-2.6.32.10.1-cpt_process.c-build.patch,
+ +files/openvz-sources-2.6.32.10.1-orphans.patch:
+ Version bump.
25 Oct 2010; Peter Volkov <pva@gentoo.org>
openvz-sources-2.6.27.7.1.ebuild:
diff --git a/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-cpt_process.c-build.patch b/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-cpt_process.c-build.patch
new file mode 100644
index 000000000000..8fe515006e80
--- /dev/null
+++ b/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-cpt_process.c-build.patch
@@ -0,0 +1,36 @@
+http://bugzilla.openvz.org/show_bug.cgi?id=1687
+
+C/R: Use in_gate_area_no_task helper to test task's checkpoint-ability v2
+
+Signed-off-by: Cyrill Gorcunov <gorcunov@openvz.org>
+---
+ arch/x86/mm/init_64.c | 1 +
+ kernel/cpt/cpt_process.c | 3 +--
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+Index: linux-2.6-openvz/arch/x86/mm/init_64.c
+=====================================================================
+--- linux-2.6-openvz.orig/arch/x86/mm/init_64.c
++++ linux-2.6-openvz/arch/x86/mm/init_64.c
+@@ -893,6 +893,7 @@ int in_gate_area_no_task(unsigned long a
+ {
+ return (addr >= VSYSCALL_START) && (addr < VSYSCALL_END);
+ }
++EXPORT_SYMBOL(in_gate_area_no_task);
+
+ const char *arch_vma_name(struct vm_area_struct *vma)
+ {
+Index: linux-2.6-openvz/kernel/cpt/cpt_process.c
+=====================================================================
+--- linux-2.6-openvz.orig/kernel/cpt/cpt_process.c
++++ linux-2.6-openvz/kernel/cpt/cpt_process.c
+@@ -40,8 +40,7 @@ int check_task_state(struct task_struct
+ {
+ #ifdef CONFIG_X86_64
+ if (!(task_thread_info(tsk)->flags&_TIF_IA32)) {
+- if (task_pt_regs(tsk)->ip >= VSYSCALL_START &&
+- task_pt_regs(tsk)->ip < VSYSCALL_END) {
++ if (in_gate_area_no_task(task_pt_regs(tsk)->ip)) {
+ eprintk_ctx(CPT_FID "cannot be checkpointied while vsyscall, try later\n", CPT_TID(tsk));
+ return -EAGAIN;
+ }
diff --git a/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-orphans.patch b/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-orphans.patch
new file mode 100644
index 000000000000..ea9893faa0dc
--- /dev/null
+++ b/sys-kernel/openvz-sources/files/openvz-sources-2.6.32.10.1-orphans.patch
@@ -0,0 +1,107 @@
+From: Pavel Emelyanov <xemul@openvz.org>
+Date: Sat, 6 Nov 2010 14:02:43 +0000 (+0300)
+Subject: ubc: Fix orphan count checks after merge
+X-Git-Url: http://git.openvz.org/?p=linux-2.6.32-openvz;a=commitdiff_plain;h=e5db932edffe86ddc4a8f9cdfc6e267ed887570c
+
+ubc: Fix orphan count checks after merge
+
+After merging -stable the orphans checking function started checking
+the wrong counter.
+
+http://bugzilla.openvz.org/show_bug.cgi?id=1693
+
+Signed-off-by: Pavel Emelyanov <xemul@openvz.org>
+---
+
+diff --git a/include/bc/sock_orphan.h b/include/bc/sock_orphan.h
+index c5b2412..8f829c3 100644
+--- a/include/bc/sock_orphan.h
++++ b/include/bc/sock_orphan.h
+@@ -19,9 +19,13 @@
+
+ static inline struct percpu_counter *__ub_get_orphan_count_ptr(struct sock *sk)
+ {
+- if (sock_has_ubc(sk))
+- return &sock_bc(sk)->ub->ub_orphan_count;
+- return sk->sk_prot->orphan_count;
++ if (sock_has_ubc(sk)) {
++ struct user_beancounter *ub;
++
++ ub = top_beancounter(sock_bc(sk)->ub);
++ return &ub->ub_orphan_count;
++ } else
++ return sk->sk_prot->orphan_count;
+ }
+
+ static inline void ub_inc_orphan_count(struct sock *sk)
+@@ -39,15 +43,7 @@ static inline int ub_get_orphan_count(struct sock *sk)
+ return percpu_counter_sum_positive(__ub_get_orphan_count_ptr(sk));
+ }
+
+-extern int __ub_too_many_orphans(struct sock *sk, int count);
+-static inline int ub_too_many_orphans(struct sock *sk, int shift)
+-{
+-#ifdef CONFIG_BEANCOUNTERS
+- if (__ub_too_many_orphans(sk, shift))
+- return 1;
+-#endif
+- return tcp_too_many_orphans(sk, shift);
+-}
++extern int ub_too_many_orphans(struct sock *sk, int count);
+
+ #include <bc/kmem.h>
+
+diff --git a/include/net/tcp.h b/include/net/tcp.h
+index 6fa5f0d..ac5f07d 100644
+--- a/include/net/tcp.h
++++ b/include/net/tcp.h
+@@ -272,9 +272,9 @@ static inline int between(__u32 seq1, __u32 seq2, __u32 seq3)
+ return seq3 - seq2 >= seq1 - seq2;
+ }
+
+-static inline bool tcp_too_many_orphans(struct sock *sk, int shift)
++static inline bool tcp_too_many_orphans(struct sock *sk,
++ struct percpu_counter *ocp, int shift)
+ {
+- struct percpu_counter *ocp = sk->sk_prot->orphan_count;
+ int orphans = percpu_counter_read_positive(ocp);
+
+ if (orphans << shift > sysctl_tcp_max_orphans) {
+diff --git a/kernel/bc/net.c b/kernel/bc/net.c
+index 2866ebb..427fc42 100644
+--- a/kernel/bc/net.c
++++ b/kernel/bc/net.c
+@@ -102,17 +102,18 @@ EXPORT_SYMBOL(skb_charge_fullsize);
+ static int ub_sock_makewreserv_locked(struct sock *sk,
+ int bufid, unsigned long size);
+
+-int __ub_too_many_orphans(struct sock *sk, int shift)
++int ub_too_many_orphans(struct sock *sk, int shift)
+ {
+- struct user_beancounter *ub;
+ struct percpu_counter *cnt;
+
++ cnt = sk->sk_prot->orphan_count;
+ if (sock_has_ubc(sk)) {
+- int orphans, limit;
++ struct user_beancounter *ub;
++ unsigned int orphans, limit;
+
+ ub = top_beancounter(sock_bc(sk)->ub);
+- limit = ((int)ub->ub_parms[UB_NUMTCPSOCK].barrier) >> 2;
+- cnt = __ub_get_orphan_count_ptr(sk);
++ limit = ub->ub_parms[UB_NUMTCPSOCK].barrier >> 2;
++ cnt = &ub->ub_orphan_count;
+
+ orphans = percpu_counter_read_positive(cnt);
+ if ((orphans << shift) >= limit)
+@@ -122,7 +123,8 @@ int __ub_too_many_orphans(struct sock *sk, int shift)
+ if ((orphans << shift) >= limit)
+ return 1;
+ }
+- return 0;
++
++ return tcp_too_many_orphans(sk, cnt, shift);
+ }
+
+ /*
diff --git a/sys-kernel/openvz-sources/openvz-sources-2.6.32.10.1.ebuild b/sys-kernel/openvz-sources/openvz-sources-2.6.32.10.1.ebuild
new file mode 100644
index 000000000000..a231d036b556
--- /dev/null
+++ b/sys-kernel/openvz-sources/openvz-sources-2.6.32.10.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openvz-sources/openvz-sources-2.6.32.10.1.ebuild,v 1.1 2010/11/09 13:55:32 pva Exp $
+
+inherit versionator
+
+# Upstream uses string to version their releases. To make portage version
+# comparisment working we have to use numbers instead of strings, that is 4th
+# component of our version. So we have aivazovsky - 1, briullov - 2 and so on.
+# Keep this string on top since we have to modify it each new release.
+OVZ_CODENAME="dzhanibekov"
+OVZ_CODENAME_SUBRELEASE=$(get_version_component_range 5)
+
+OVZ_KV="${OVZ_CODENAME}.${OVZ_CODENAME_SUBRELEASE}"
+
+ETYPE="sources"
+
+CKV=$(get_version_component_range 1-3)
+OKV=${OKV:-${CKV}}
+EXTRAVERSION=-${PN/-*}-${OVZ_KV}
+KV_FULL=${CKV}${EXTRAVERSION}
+if [[ ${PR} != r0 ]]; then
+ KV_FULL+=-${PR}
+ EXTRAVERSION+=-${PR}
+fi
+
+# ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} should succeed.
+KV_MAJOR=$(get_version_component_range 1 ${OKV})
+KV_MINOR=$(get_version_component_range 2 ${OKV})
+KV_PATCH=$(get_version_component_range 3 ${OKV})
+
+KERNEL_URI="mirror://kernel/linux/kernel/v${KV_MAJOR}.${KV_MINOR}/linux-${OKV}.tar.bz2"
+
+inherit kernel-2
+detect_version
+
+SLOT=${CKV}-${OVZ_KV}
+if [[ ${PR} != r0 ]]; then
+ SLOT+=-${PR}
+fi
+
+KEYWORDS="~amd64 ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DESCRIPTION="Kernel sources with OpenVZ patchset"
+HOMEPAGE="http://www.openvz.org"
+SRC_URI="${KERNEL_URI} ${ARCH_URI}
+ http://download.openvz.org/kernel/branches/${CKV}/${CKV}-${OVZ_KV}/patches/patch-${OVZ_KV}-combined.gz"
+
+UNIPATCH_STRICTORDER=1
+UNIPATCH_LIST="${DISTDIR}/patch-${OVZ_KV}-combined.gz
+${FILESDIR}/${P}-cpt_process.c-build.patch
+${FILESDIR}/${P}-orphans.patch"
+
+K_EXTRAEINFO="For more information about this kernel take a look at:
+http://wiki.openvz.org/Download/kernel/${CKV}/${CKV}-${OVZ_KV}"