summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-01-17 05:34:31 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-01-17 05:34:31 +0000
commitee9bf8efc04d69577d4f776027cd5c5bc3cb97e7 (patch)
treeb889d5f928a9914cdb5d71165a66229607adb83b /sys-kernel/linux-sources
parentnew funky kernel (diff)
downloadgentoo-2-ee9bf8efc04d69577d4f776027cd5c5bc3cb97e7.tar.gz
gentoo-2-ee9bf8efc04d69577d4f776027cd5c5bc3cb97e7.tar.bz2
gentoo-2-ee9bf8efc04d69577d4f776027cd5c5bc3cb97e7.zip
kernel-rama
Diffstat (limited to 'sys-kernel/linux-sources')
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17.ebuild206
1 files changed, 0 insertions, 206 deletions
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17.ebuild
deleted file mode 100644
index 1b038b366feb..000000000000
--- a/sys-kernel/linux-sources/linux-sources-2.4.17.ebuild
+++ /dev/null
@@ -1,206 +0,0 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17.ebuild,v 1.3 2001/12/30 22:44:35 azarah Exp $
-
-#OKV=original kernel version, KV=patched kernel version. They can be the same.
-
-#we use this next variable to avoid duplicating stuff on cvs
-GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
-OKV=${PV}
-KV=${OKV}
-S=${WORKDIR}/linux-${KV}
-S2=${WORKDIR}/linux-${KV}-extras
-
-# Patch versions. We now have a new system. To enable a patch, set the patch version. To disable
-# a patch, comment out the patch version and it won't be enabled. In this ebuild, ACPI, low latency
-# and preempt patches are enabled, but MOSIX is not.
-
-#XFS patch
-XFSV=20011214
-#ACPI patch
-ACPIV=20011205
-#Low latency patch
-#LOWLV=${KV}
-#Preemptive kernel patch
-PREEV="${KV}-1"
-#Lock-break patch
-LBPV="${KV}-2"
-#Bridge/netfilter compatibility patch
-BNFV="0.0.5pre3"
-#MOSIX patch
-#MOSV=1.5.2
-
-DESCRIPTION="Linux kernel version ${KV} - full sources"
-
-PATCHES=""
-SRC_URI="http://www.de.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2"
-[ "$MOSV" ] && { SRC_URI="$SRC_URI http://www.mosix.cs.huji.ac.il/ftps/MOSIX-${MOSV}.tar.gz"; PATCHES="$PATCHES ${S2}/MOSIX-${MOSV}/patches.${OKV}"; }
-[ "$ACPIV" ] && { SRC_URI="$SRC_URI http://developer.intel.com/technology/iapc/acpi/downloads/acpi-${ACPIV}.diff.gz"; PATCHES="$PATCHES ${DISTDIR}/acpi-${ACPIV}.diff.gz"; }
-[ "$LOWLV" ] && { SRC_URI="$SRC_URI http://www.zip.com.au/~akpm/linux/${LOWLV}-low-latency.patch.gz"; PATCHES="$PATCHES ${DISTDIR}/${LOWLV}-low-latency.patch.gz"; }
-[ "$PREEV" ] && { SRC_URI="$SRC_URI http://www.kernel.org/pub/linux/kernel/people/rml/preempt-kernel/v2.4/preempt-kernel-rml-${PREEV}.patch"; PATCHES="$PATCHES ${DISTDIR}/preempt-kernel-rml-${PREEV}.patch"; }
-[ "$LBPV" ] && { SRC_URI="$SRC_URI http://www.kernel.org/pub/linux/kernel/people/rml/lock-break/v2.4/lock-break-rml-${LBPV}.patch"; PATCHES="$PATCHES ${DISTDIR}/lock-break-rml-${LBPV}.patch"; }
-[ "$XFSV" ] && { SRC_URI="$SRC_URI http://www.ibiblio.org/gentoo/distfiles/XFS-${XFSV}.patch.bz2"; PATCHES="$PATCHES ${DISTDIR}/XFS-${XFSV}.patch.bz2"; }
-[ "$BNFV" ] && { SRC_URI="$SRC_URI http://bridge.sourceforge.net/devel/bridge-nf/bridge-nf-${BNFV}-against-${KV}.diff"; PATCHES="$PATCHES ${DISTDIR}/bridge-nf-${BNFV}-against-${KV}.diff"; }
-
-
-PROVIDE="virtual/kernel"
-HOMEPAGE="http://www.kernel.org/ http://www.namesys.com http://www.sistina.com/lvm/ http://developer.intel.com/technology/iapc/acpi/"
-
-if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
-then
- #console-tools is needed to solve the loadkeys fiasco.
- #binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
- DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-apps/console-tools >=sys-apps/modutils-2.4.2 sys-devel/perl"
- RDEPEND=">=sys-libs/ncurses-5.2"
-fi
-
-[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
-
-#modified to be able to patch a external patch with our own one in
-#${FILESDIR}/${PVR}/to fix rejects. our patch have the same name, but not
-#the .gz or .bz2 extension.
-#this is usefull in that you dont have to have lots of versions of a single
-#patch for every ebuild on ibiblio, and decrease the time to release a ebuild.
-patchorama() {
- local curdir="`pwd`"
- local x
- local patchdir=${T}/patch
- for x in ${*}
- do
- [ -d "$x" ] && continue
- echo ">>> Applying ${x}..."
- [ ! -d ${patchdir} ] && mkdir ${patchdir}
- cd ${patchdir}
- if [ "${x##*.}" = "bz2" ]
- then
- x=${x%%.bz2}
- bzip2 -dc ${x}.bz2 > ${patchdir}/${x##*/} || die
- elif [ "${x##*.}" = "gz" ]
- then
- x=${x%%.gz}
- gzip -dc ${x}.gz > ${patchdir}/${x##*/} || die
- else
- cp ${x} ${patchdir}
- fi
- x=${patchdir}/${x##*/}
- if [ -f ${FILESDIR}/${PVR}/${x##*/} ]
- then
- echo ">>> Fixing ${x##*/} for use with Gentoo..."
- patch < ${FILESDIR}/${PVR}/${x##*/} || {
- echo
- echo "!!!Failed to fix ${x##*/}!!!"
- echo
- die
- }
- fi
- cd ${curdir}
- patch -p1 -l < ${x} || {
- echo
- echo "!!!Failed to apply ${x##*/}!!!"
- echo "Check that you are not missing patches in:"
- echo
- echo " ${FILESDIR}/${PVR}/"
- echo
- die
- }
- done
-}
-
-src_unpack() {
- mkdir ${S2}
-
- cd ${WORKDIR}
- unpack linux-${OKV}.tar.bz2
- mv linux linux-${KV} || die
- dodir /usr/src/linux-${KV}-extras
- if [ "$MOSIX" ]
- then
- cd ${S2}
- tar -xz --no-same-owner -f ${DISTDIR}/MOSIX-${MOSV}.tar.gz MOSIX-${MOSV}/patches.${OKV}
- fi
- cd ${S}
- patchorama $PATCHES
- echo "Removing -xfs extension from the kernel..."
- cp Makefile Makefile.orig
- sed -e 's:EXTRAVERSION =-xfs:EXTRAVERSION =:g' Makefile.orig > Makefile
- echo "Preparing for compilation..."
-
- #sometimes we have icky kernel symbols; this seems to get rid of them
- make mrproper || die
-
- #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
- cp ${S}/arch/i386/defconfig .config || die
- yes "" | make oldconfig
- echo "Ignore any errors from the yes command above."
-
- #fix silly permissions in tarball
- cd ${WORKDIR}
- chown -R 0.0 *
- chmod -R a+r-w+X,u+w *
-
- # Gentoo Linux uses /boot, so fix 'make install' to work properly
- cd ${S}
- mv Makefile Makefile.orig
- sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
- Makefile.orig >Makefile || die # test, remove me if Makefile ok
- rm Makefile.orig
-}
-
-src_compile() {
- if [ "${PN}" = "linux-headers" ]
- then
- cd ${S}
- make include/linux/autoconf.h include/linux/version.h || die
- fi
-}
-
-src_install() {
- if [ "$PN" = "linux-sources" ]
- then
- dodir /usr/src
- cd ${S}
- echo ">>> Copying sources..."
- cp -ax ${WORKDIR}/* ${D}/usr/src
- elif [ "$PN" = "linux-headers" ]
- then
- dodir /usr/include/linux
- cp -ax ${S}/include/linux/* ${D}/usr/include/linux
- dodir /usr/include/asm
- cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
- fi
- if [ -d ${D}/usr/src/linux-${KV} ]
- then
- cd ${D}/usr/src/linux-${KV}
- if [ -e .config ]
- then
- mv .config .config.eg
- fi
- fi
-}
-
-pkg_preinst() {
- if [ "$PN" = "linux-headers" ]
- then
- if [ -L ${ROOT}usr/include/linux ]
- then
- rm ${ROOT}usr/include/linux
- fi
- if [ -L ${ROOT}usr/include/asm ]
- then
- rm ${ROOT}usr/include/asm
- fi
- fi
-}
-
-pkg_postinst() {
- [ "$PN" = "linux-headers" ] && return
- rm -f ${ROOT}/usr/src/linux
- ln -sf linux-${KV} ${ROOT}/usr/src/linux
- #copy over our .config if one isn't already present
- cd ${ROOT}/usr/src/linux-${KV}
- if [ "${PN}" = "linux-sources" ] && [ -e .config.eg ] && [ ! -e .config ]
- then
- cp -a .config.eg .config
- fi
-}