summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-04-05 22:51:56 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-04-05 22:51:56 +0000
commitc1b068beed464bd4851594fa3e469956ae4f15ee (patch)
tree0271cfa51ac1b36be110d76a223f0e203d52ea9a /sys-kernel/linux-sources
parentremoving bigus kde.us.org server (again) (diff)
downloadgentoo-2-c1b068beed464bd4851594fa3e469956ae4f15ee.tar.gz
gentoo-2-c1b068beed464bd4851594fa3e469956ae4f15ee.tar.bz2
gentoo-2-c1b068beed464bd4851594fa3e469956ae4f15ee.zip
new 2.4.19-r1 kernel, just to make vmware compatible again.
Diffstat (limited to 'sys-kernel/linux-sources')
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.19-r12
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild115
2 files changed, 117 insertions, 0 deletions
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.19-r1 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.19-r1
new file mode 100644
index 000000000000..cab71cdc55b6
--- /dev/null
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.19-r1
@@ -0,0 +1,2 @@
+MD5 ad92859baaa837847b34d842b9f39d38 linux-2.4.18.tar.bz2 24161675
+MD5 49331e039d3847b2c353913f9b36037b linux-gentoo-2.4.19-r1.patch.bz2 4023938
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild
new file mode 100644
index 000000000000..59daef5debf9
--- /dev/null
+++ b/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.19-r1.ebuild,v 1.1 2002/04/05 22:51:56 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.18
+KV=2.4.19-r1
+S=${WORKDIR}/linux-${KV}
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19-pre2 stock kernel, plus:
+# 2.4.19-pre2-ac4 patch, plus:
+# SGI XFS (28 Mar 2002 CVS)
+
+# Changes from 2.4.19 ebuild:
+# including linux/malloc.h is back to a warning to fix vmware compatibility
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+PROVIDE="virtual/kernel"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$PN" = "linux-sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$PN" = "linux-headers" ] && return
+ cd ${ROOT}usr/src/linux-${KV}
+ make mrproper
+ if [ -e "${ROOT}usr/src/linux/.config" ]
+ then
+ cp "${ROOT}usr/src/linux/.config" .config
+ #we only make dep when upgrading to a new kernel (with existing config)
+ #The default setting will be selected.
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ make dep
+ else
+ cp "${ROOT}usr/src/linux-${KV}/arch/i386/defconfig" .config
+ fi
+ #remove /usr/src/linux symlink
+ rm -f ${ROOT}/usr/src/linux
+ #set up a new one
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+}