summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-15 05:41:58 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-15 05:41:58 +0000
commit74dfbeb3bb7c21d429da0fe39c3ba4f03ff621ab (patch)
tree3b4d90a9de8aa4868b2968f40af9c7a0f8aec9ac /sys-kernel/linux-sources
parentmissing digest reunion (diff)
downloadgentoo-2-74dfbeb3bb7c21d429da0fe39c3ba4f03ff621ab.tar.gz
gentoo-2-74dfbeb3bb7c21d429da0fe39c3ba4f03ff621ab.tar.bz2
gentoo-2-74dfbeb3bb7c21d429da0fe39c3ba4f03ff621ab.zip
new 2.4.17-r5 kernel; see ChangeLog for more info.
Diffstat (limited to 'sys-kernel/linux-sources')
-rw-r--r--sys-kernel/linux-sources/ChangeLog10
-rw-r--r--sys-kernel/linux-sources/files/digest-linux-sources-2.4.17-r52
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild146
3 files changed, 157 insertions, 1 deletions
diff --git a/sys-kernel/linux-sources/ChangeLog b/sys-kernel/linux-sources/ChangeLog
index e9d08f89b187..6a59d4edad15 100644
--- a/sys-kernel/linux-sources/ChangeLog
+++ b/sys-kernel/linux-sources/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/linux-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/ChangeLog,v 1.2 2002/02/14 05:08:01 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/ChangeLog,v 1.3 2002/02/15 05:41:58 drobbins Exp $
+
+*linux-sources-2.4.17-r5 (14 Feb 2002)
+
+ 14 Feb 2002; Daniel Robbins <drobbins@gentoo.org>:
+ acpi-20020214-2.4.17.diff.gz added back since it closes bug #689;
+ ide-2.4.17.02072002.patch has been removed due to bug #690 and will be added
+ back when this bug is closed (The existence of this bug has been confirmed
+ with the patch author)
*linux-sources-2.4.17-r4 (13 Feb 2002)
diff --git a/sys-kernel/linux-sources/files/digest-linux-sources-2.4.17-r5 b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.17-r5
new file mode 100644
index 000000000000..6c8893605957
--- /dev/null
+++ b/sys-kernel/linux-sources/files/digest-linux-sources-2.4.17-r5
@@ -0,0 +1,2 @@
+MD5 0628d142eeb6fc31856d7a60d3f30a82 linux-2.4.17.tar.bz2 23841012
+MD5 35ab65b7b1d030e56bec8be730ab857e linux-gentoo-2.4.17-r5.patch.bz2 1192930
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
new file mode 100644
index 000000000000..2f2896fb84a6
--- /dev/null
+++ b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
@@ -0,0 +1,146 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.1 2002/02/15 05:41:58 drobbins Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=${PV}
+KV=${PVR}
+S=${WORKDIR}/linux-${KV}
+S2=${WORKDIR}/linux-${KV}-extras
+
+# What's in this kernel?
+
+# INCLUDED:
+# xfs (13 Feb 2002 CVS)
+# read-latency2.patch from http://www.zipworld.com.au/~akpm/linux/2.4/2.4.18-pre9/
+# (improves multiple disk read/write IO performance)
+# fastpte
+# (enables an option to do fast scanning of the page tables)
+# preempt-kernel-rml-2.4.17-3 from http://www.tech9.net/rml/linux/
+# (preemptible kernel)
+# loopback device deadlock fixes from akpm
+
+# ADDED in 2.4.17-r5:
+# acpi-20020214-2.4.17.diff.gz from http://sourceforge.net/projects/acpi
+# This patch should close bug #689 which was sent upstream.
+
+# REMOVED from 2.4.17-r5:
+# ide.2.4.17.02072002.patch from http://www.linuxdiskcert.org/
+# (revamped IDE code; this closes bug #690; we'll add it back as soon as the
+# confirmed with author completion error is fixed (probably in the next release))
+
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2"
+PROVIDE="virtual/kernel"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+XFSV=20020124
+
+if [ $PN = "linux-sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco.
+ #binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31 sys-apps/console-tools >=sys-apps/modutils-2.4.2 sys-devel/perl"
+ RDEPEND=">=sys-libs/ncurses-5.2 >=sys-apps/xfsprogs-${XFSV} >=sys-apps/dmapi-${XFSV} >=sys-apps/attr-${XFSV} >=sys-apps/acl-${XFSV} >=sys-apps/xfsdump-${XFSV}"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ mkdir ${S2}
+
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ dodir /usr/src/linux-${KV}-extras
+ if [ "$MOSIX" ]
+ then
+ cd ${S2}
+ tar -xz --no-same-owner -f ${DISTDIR}/MOSIX-${MOSV}.tar.gz MOSIX-${MOSV}/patches.${OKV}
+ fi
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+ echo "Preparing for compilation..."
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #linux-sources needs to be fully configured, too. This is the configuration for the default kernel
+ cp ${S}/arch/i386/defconfig .config || die
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "${PN}" = "linux-headers" ]
+ then
+ cd ${S}
+ make include/linux/autoconf.h include/linux/version.h || die
+ fi
+}
+
+src_install() {
+ if [ "$PN" = "linux-sources" ]
+ then
+ dodir /usr/src
+ cd ${S}
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ elif [ "$PN" = "linux-headers" ]
+ then
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+ if [ -d ${D}/usr/src/linux-${KV} ]
+ then
+ cd ${D}/usr/src/linux-${KV}
+ if [ -e .config ]
+ then
+ mv .config .config.eg
+ fi
+ fi
+}
+
+pkg_preinst() {
+ if [ "$PN" = "linux-headers" ]
+ then
+ if [ -L ${ROOT}usr/include/linux ]
+ then
+ rm ${ROOT}usr/include/linux
+ fi
+ if [ -L ${ROOT}usr/include/asm ]
+ then
+ rm ${ROOT}usr/include/asm
+ fi
+ fi
+}
+
+pkg_postinst() {
+ [ "$PN" = "linux-headers" ] && return
+ rm -f ${ROOT}/usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ #copy over our .config if one isn't already present
+ cd ${ROOT}/usr/src/linux-${KV}
+ if [ "${PN}" = "linux-sources" ] && [ -e .config.eg ] && [ ! -e .config ]
+ then
+ cp -a .config.eg .config
+ fi
+}