summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-27 02:26:17 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-27 02:26:17 +0000
commite10f1e57935555428441e5c4b5407ce3572fbb93 (patch)
treef2992c7fc6efe6a510708ef03e5b204be80e0fa7 /sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild
parentold (diff)
downloadgentoo-2-e10f1e57935555428441e5c4b5407ce3572fbb93.tar.gz
gentoo-2-e10f1e57935555428441e5c4b5407ce3572fbb93.tar.bz2
gentoo-2-e10f1e57935555428441e5c4b5407ce3572fbb93.zip
Fix fcntl.h conflicts #244470.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild
new file mode 100644
index 000000000000..f792319391d0
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.27-r2.ebuild,v 1.1 2008/10/27 02:26:17 vapier Exp $
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arm cris hppa m68k mips ia64 ppc ppc64 s390 sh sparc x86"
+inherit kernel-2
+detect_version
+
+PATCH_VER="2"
+SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.lzma"
+[[ -n ${PATCH_VER} ]] && SRC_URI="${SRC_URI} mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.lzma"
+
+KEYWORDS="-* ~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+DEPEND="app-arch/lzma-utils"
+RDEPEND=""
+
+S=${WORKDIR}/gentoo-headers-base-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+}
+
+src_install() {
+ kernel-2_src_install
+ cd "${D}"
+ egrep -r \
+ -e '[[:space:]](asm|volatile|inline)[[:space:](]' \
+ -e '\<([us](8|16|32|64))\>' \
+ .
+ headers___fix $(find -type f)
+
+ # hrm, build system sucks
+ find "${D}" '(' -name '.install' -o -name '*.cmd' ')' -print0 | xargs -0 rm -f
+
+ # provided by libdrm (for now?)
+ rm -rf "${D}"/usr/include/drm
+}
+
+src_test() {
+ emake -j1 ARCH=$(tc-arch-kernel) headers_check || die
+}