summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-01-22 15:18:45 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-01-22 15:18:45 +0000
commitcaae756fc65899ac8cc1fd47a0e2fd5e6a207ed6 (patch)
treec9f08f4b7cd7c1d641c70635e1f25091b862ec39 /sys-kernel/hardened-sources
parenttake over maintainership with Alex Xu as proxy (diff)
downloadgentoo-2-caae756fc65899ac8cc1fd47a0e2fd5e6a207ed6.tar.gz
gentoo-2-caae756fc65899ac8cc1fd47a0e2fd5e6a207ed6.tar.bz2
gentoo-2-caae756fc65899ac8cc1fd47a0e2fd5e6a207ed6.zip
vanilla-3.2.54 + genpatches-3.2-16 + grsecurity-3.0-3.2.54-201401191012
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-3.2.54-r3.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 5ea17c375da1..c1b10abf1193 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.979 2014/01/20 16:17:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.980 2014/01/22 15:18:45 blueness Exp $
+
+*hardened-sources-3.2.54-r3 (22 Jan 2014)
+
+ 22 Jan 2014; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-3.2.54-r3.ebuild:
+ vanilla-3.2.54 + genpatches-3.2-16 + grsecurity-3.0-3.2.54-201401191012
*hardened-sources-3.10.1-r1 (20 Jan 2014)
diff --git a/sys-kernel/hardened-sources/hardened-sources-3.2.54-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-3.2.54-r3.ebuild
new file mode 100644
index 000000000000..862d58e50ee3
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-3.2.54-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-3.2.54-r3.ebuild,v 1.1 2014/01/22 15:18:45 blueness Exp $
+
+EAPI="5"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="16"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-3.0*"
+
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}