summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2008-12-07 00:13:02 +0000
committerGordon Malm <gengor@gentoo.org>2008-12-07 00:13:02 +0000
commitbd3ed8e5061a44ef8de3cabd749fe33954264fd7 (patch)
tree5023046650d2525663784634f37f3332b7ba7389 /sys-kernel/hardened-sources
parentBumping to 1.0.1, closing #246548 (diff)
downloadgentoo-2-bd3ed8e5061a44ef8de3cabd749fe33954264fd7.tar.gz
gentoo-2-bd3ed8e5061a44ef8de3cabd749fe33954264fd7.tar.bz2
gentoo-2-bd3ed8e5061a44ef8de3cabd749fe33954264fd7.zip
Add hardened-sources-2.6.27-r3.
(Portage version: 2.1.4.5)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.27-r3.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index d33d74d4da76..02bed5696eda 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.264 2008/12/03 05:07:16 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.265 2008/12/07 00:13:02 gengor Exp $
+
+*hardened-sources-2.6.27-r3 (07 Dec 2008)
+
+ 07 Dec 2008; Gordon Malm <gengor@gentoo.org>
+ +hardened-sources-2.6.27-r3.ebuild:
+ Bump to latest genpatches, including Linux 2.6.27.8. Bump grsec/pax patches.
+ Fixes bug #248754, #249729 and #246607.
03 Dec 2008; Gordon Malm <gengor@gentoo.org>
-hardened-sources-2.6.25-r9.ebuild, -hardened-sources-2.6.26-r5.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.27-r3.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r3.ebuild
new file mode 100644
index 000000000000..a924978a1c54
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.27-r3.ebuild,v 1.1 2008/12/07 00:13:02 gengor Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="7"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-4"
+HGPV_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.4.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.1.12*"
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.24,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with kernel series ${OKV}."
+ ewarn "Therefore, it is strongly recommended that the following command is"
+ ewarn "issued prior to booting a ${P} series kernel for"
+ ewarn "the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}