summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-11-20 14:41:16 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-11-20 14:41:16 +0000
commitabb69bc5af509578463d1918443a97b0524c035c (patch)
treec84f47e8ecca140bf9aa42555b1a0afbf81cb68e /sys-kernel/hardened-sources
parentDo not enable mathfp, it is considered unstable/broken code. (diff)
downloadgentoo-2-abb69bc5af509578463d1918443a97b0524c035c.tar.gz
gentoo-2-abb69bc5af509578463d1918443a97b0524c035c.tar.bz2
gentoo-2-abb69bc5af509578463d1918443a97b0524c035c.zip
vanilla-2.6.32.60 + genpatches-2.6.32-48 + grsecurity-2.9.1-2.6.32.60-201211181103
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r140.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 27af14245858..41f756402aaf 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.726 2012/11/14 11:44:55 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.727 2012/11/20 14:41:16 blueness Exp $
+
+*hardened-sources-2.6.32-r140 (20 Nov 2012)
+
+ 20 Nov 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r140.ebuild:
+ vanilla-2.6.32.60 + genpatches-2.6.32-48 +
+ grsecurity-2.9.1-2.6.32.60-201211181103
14 Nov 2012; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-2.6.32-r137.ebuild, -hardened-sources-3.6.5.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r140.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r140.ebuild
new file mode 100644
index 000000000000..6d21fb667131
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r140.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r140.ebuild,v 1.1 2012/11/20 14:41:16 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-144"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}