summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-01-29 23:35:59 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-01-29 23:35:59 +0000
commit61cf6352c72975a2055b36f63eaf6f5febe2ca84 (patch)
treeb90311cdeb6b6a308e8424a62eff353d5e68713d /sys-kernel/hardened-sources
parentadd missing ppc64 stable keyword (diff)
downloadgentoo-2-61cf6352c72975a2055b36f63eaf6f5febe2ca84.tar.gz
gentoo-2-61cf6352c72975a2055b36f63eaf6f5febe2ca84.tar.bz2
gentoo-2-61cf6352c72975a2055b36f63eaf6f5febe2ca84.zip
Based on vanilla 2.6.32.28 + genpatches-2.6.32-30 + grsecurity-2.2.1-2.6.32.28-201101272313
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r36.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 2b958049ab20..87a2c1789126 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.382 2011/01/28 02:19:37 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.383 2011/01/29 23:35:59 blueness Exp $
+
+*hardened-sources-2.6.32-r36 (29 Jan 2011)
+
+ 29 Jan 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r36.ebuild:
+ Based on vanilla 2.6.32.28 + genpatches-2.6.32-30 +
+ grsecurity-2.2.1-2.6.32.28-201101272313
28 Jan 2011; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-2.6.32-r30.ebuild, -hardened-sources-2.6.32-r32.ebuild,
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r36.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r36.ebuild
new file mode 100644
index 000000000000..680793f570c4
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r36.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r36.ebuild,v 1.1 2011/01/29 23:35:59 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="30"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-39"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides four different predefined grsecurity level:"
+ ewarn "[server], [server no rbac] [workstation] [workstation no rbac]"
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}