summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2008-11-09 23:41:37 +0000
committerGordon Malm <gengor@gentoo.org>2008-11-09 23:41:37 +0000
commit473014d702551f2fdd25653b77c36d8abe0b8d6f (patch)
treed92b277d74a0d17162bf5fdefabe8825fb61b13c /sys-kernel/hardened-sources
parentRemove unnecessary gnome-python-extras dependency and add a revision that use... (diff)
downloadgentoo-2-473014d702551f2fdd25653b77c36d8abe0b8d6f.tar.gz
gentoo-2-473014d702551f2fdd25653b77c36d8abe0b8d6f.tar.bz2
gentoo-2-473014d702551f2fdd25653b77c36d8abe0b8d6f.zip
Version bump, 2.6.27-r1.
(Portage version: 2.1.4.5)
Diffstat (limited to 'sys-kernel/hardened-sources')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog8
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.27-r1.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index f1ff1bd1d54b..b9365e676b35 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.252 2008/11/04 06:13:28 gengor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.253 2008/11/09 23:41:37 gengor Exp $
+
+*hardened-sources-2.6.27-r1 (09 Nov 2008)
+
+ 09 Nov 2008; Gordon Malm <gengor@gentoo.org>
+ +hardened-sources-2.6.27-r1.ebuild:
+ Bump to stable kernel 2.6.27.5 and latest grsecurity patch.
*hardened-sources-2.6.27 (04 Nov 2008)
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.27-r1.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r1.ebuild
new file mode 100644
index 000000000000..4a935d7f4203
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.27-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.27-r1.ebuild,v 1.1 2008/11/09 23:41:37 gengor Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="4"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-2"
+HGPV_URI="http://dev.gentoo.org/~gengor/distfiles/${CATEGORY}/${PN}/hardened-patches-${HGPV}.extras.tar.bz2
+ mirror://gentoo/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2000_tcp-option-ordering-restore.patch 4200_fbcondecor-0.9.4.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.1.12*"
+
+ ewarn
+ ewarn "As of ${CATEGORY}/${PN}-2.6.24 the predefined"
+ ewarn "\"Hardened [Gentoo]\" grsecurity level has been removed."
+ ewarn "Two improved predefined security levels replace it:"
+ ewarn "\"Hardened Gentoo [server]\" and \"Hardened Gentoo [workstation]\""
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.24,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with kernel series ${OKV}."
+ ewarn "Therefore, it is strongly recommended that the following command is"
+ ewarn "issued prior to booting a ${P} series kernel for"
+ ewarn "the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}