summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-03-22 12:44:54 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-03-22 12:44:54 +0000
commite3ee9e0e9666029e2464e604c0e8ac31299ed7cb (patch)
treebc60b0bdd5883b1e4c0e0fb31ae74250389b4b78 /sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild
parentBased on vanilla 2.6.32.33 + genpatches-2.6.32.34 + grsecurity-2.2.1-2.6.32.3... (diff)
downloadgentoo-2-e3ee9e0e9666029e2464e604c0e8ac31299ed7cb.tar.gz
gentoo-2-e3ee9e0e9666029e2464e604c0e8ac31299ed7cb.tar.bz2
gentoo-2-e3ee9e0e9666029e2464e604c0e8ac31299ed7cb.zip
Based on vanilla 2.6.37.4 + genpatches-2.6.37.5 + grsecurity-2.2.1-2.6.37.4-201103211735
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild
new file mode 100644
index 000000000000..7b2515420291
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.37-r7.ebuild,v 1.1 2011/03/22 12:44:54 blueness Exp $
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="5"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-8"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.1*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}