summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-06-16 17:59:49 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-06-16 17:59:49 +0000
commit7c5df9ccbc6713bb0fbfeaf31b4a4d365db02b99 (patch)
treed7edccc8903653a2890c3ef57a5669eaa341b5c9 /sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild
parentBump (diff)
downloadgentoo-2-7c5df9ccbc6713bb0fbfeaf31b4a4d365db02b99.tar.gz
gentoo-2-7c5df9ccbc6713bb0fbfeaf31b4a4d365db02b99.tar.bz2
gentoo-2-7c5df9ccbc6713bb0fbfeaf31b4a4d365db02b99.zip
Bump
Diffstat (limited to 'sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild')
-rw-r--r--sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild b/sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild
new file mode 100644
index 000000000000..48b568c6d025
--- /dev/null
+++ b/sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/ac-sources/ac-sources-2.4.21-r1.ebuild,v 1.1 2003/06/16 17:59:44 lostlogic Exp $
+
+IUSE="build"
+
+# OKV=original kernel version, KV=patched kernel version.
+
+ETYPE="sources"
+
+inherit kernel || die
+
+OKV="2.4.21"
+ACV=ac${PR/r/}
+KV="${PV/_/-}-${ACV}"
+S=${WORKDIR}/linux-${KV}
+
+EXTRAVERSION="`echo ${KV}|sed -e 's:[^-]*\(-.*$\):\1:'`"
+BASE="`echo ${KV}|sed -e s:${EXTRAVERSION}::`"
+
+DESCRIPTION="Full sources for Alan Cox's Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+http://www.kernel.org/pub/linux/kernel/people/alan/linux-2.4/${BASE}/patch-${KV}.bz2"
+#http://www.kernel.org/pub/linux/kernel/v2.4/testing/patch-${PV/_/-}.bz2"
+
+KEYWORDS="x86"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+
+ cd linux-${KV}
+# bzcat ${DISTDIR}/patch-${PV/_/-}.bz2|patch -p1 || die "-marcelo patch failed"
+ bzcat ${DISTDIR}/patch-${KV}.bz2|patch -p1 || die "-ac patch failed"
+
+ kernel_universal_unpack
+}