summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-12-28 02:16:56 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-12-28 02:16:56 +0000
commited93126dac630ad7fd1a5c9ea4287101838c0d2b (patch)
tree13539444672b2fb18312cc5d294d9248b5404ce5 /sys-fs
parentFix name of submitter for bug (s/Lasage/Lesage/) (diff)
downloadgentoo-2-ed93126dac630ad7fd1a5c9ea4287101838c0d2b.tar.gz
gentoo-2-ed93126dac630ad7fd1a5c9ea4287101838c0d2b.tar.bz2
gentoo-2-ed93126dac630ad7fd1a5c9ea4287101838c0d2b.zip
Fix ldap compile bug #203285.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/ChangeLog5
-rw-r--r--sys-fs/quota/quota-3.15.ebuild8
2 files changed, 9 insertions, 4 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index 7168df2d3a89..8e5f072e3101 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/quota
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.32 2007/12/24 12:00:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.33 2007/12/28 02:16:56 robbat2 Exp $
+
+ 28 Dec 2007; Robin H. Johnson <robbat2@gentoo.org> quota-3.15.ebuild:
+ Fix ldap compile bug #203285.
*quota-3.15 (24 Dec 2007)
diff --git a/sys-fs/quota/quota-3.15.ebuild b/sys-fs/quota/quota-3.15.ebuild
index 25637ad375f2..94697c0f1258 100644
--- a/sys-fs/quota/quota-3.15.ebuild
+++ b/sys-fs/quota/quota-3.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.15.ebuild,v 1.1 2007/12/24 12:00:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.15.ebuild,v 1.2 2007/12/28 02:16:56 robbat2 Exp $
inherit eutils flag-o-matic
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
IUSE="nls tcpd ldap rpc"
-RDEPEND="ldap? ( net-nds/openldap )
+RDEPEND="ldap? ( >=net-nds/openldap-2.3.35 )
tcpd? ( sys-apps/tcp-wrappers )
rpc? ( net-nds/portmap )"
DEPEND="${RDEPEND}
@@ -32,7 +32,9 @@ src_unpack() {
# Don't strip binaries (from Fedora)
epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
- append-cppflags -DLDAP_DEPRECATED=1
+ # This was for openldap-2.2 support before,
+ # Now we only support >=2.3
+ append-cppflags -DLDAP_DEPRECATED=0
sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
}