summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-08-01 19:45:31 +0000
committerHanno Böck <hanno@gentoo.org>2009-08-01 19:45:31 +0000
commiteb0caeed4e4ddb6400e7bddadb0d45fb1a7e2070 (patch)
tree001530748ac1e09b6b424462e059ae0c452df063 /sys-fs
parentfix metadata newline (diff)
downloadgentoo-2-eb0caeed4e4ddb6400e7bddadb0d45fb1a7e2070.tar.gz
gentoo-2-eb0caeed4e4ddb6400e7bddadb0d45fb1a7e2070.tar.bz2
gentoo-2-eb0caeed4e4ddb6400e7bddadb0d45fb1a7e2070.zip
ddrescue bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ddrescue/ChangeLog7
-rw-r--r--sys-fs/ddrescue/ddrescue-1.11.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/sys-fs/ddrescue/ChangeLog b/sys-fs/ddrescue/ChangeLog
index 9e852f934faf..64e98a45b9c5 100644
--- a/sys-fs/ddrescue/ChangeLog
+++ b/sys-fs/ddrescue/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/ddrescue
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.18 2009/07/08 22:05:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ChangeLog,v 1.19 2009/08/01 19:45:31 hanno Exp $
+
+*ddrescue-1.11 (01 Aug 2009)
+
+ 01 Aug 2009; Hanno Boeck <hanno@gentoo.org> +ddrescue-1.11.ebuild:
+ Version bump.
08 Jul 2009; Christian Faulhammer <fauli@gentoo.org> ddrescue-1.9.ebuild:
fix QA warnings: Assign RDEPEND and shorten description
diff --git a/sys-fs/ddrescue/ddrescue-1.11.ebuild b/sys-fs/ddrescue/ddrescue-1.11.ebuild
new file mode 100644
index 000000000000..85af468003bc
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ddrescue/ddrescue-1.11.ebuild,v 1.1 2009/08/01 19:45:31 hanno Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Copies data from one file or block device to another with read-error recovery"
+HOMEPAGE="http://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ # not a normal configure script
+ ./configure \
+ --prefix=/usr \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man || die "make install failed"
+ dodoc ChangeLog README NEWS AUTHORS
+}