summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-10-11 20:26:57 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-10-11 20:26:57 +0000
commitda47ee7a1569a687a4cb25d5c898d40a18a82e17 (patch)
tree697070cea357e2a7c5209003a86d94f481aed74f /sys-fs
parentapp-editors/mlview: update gtksourceview deps (see bug #195366) (diff)
downloadgentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.tar.gz
gentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.tar.bz2
gentoo-2-da47ee7a1569a687a4cb25d5c898d40a18a82e17.zip
Version bump
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dazuko/ChangeLog7
-rw-r--r--sys-fs/dazuko/dazuko-2.3.4.ebuild88
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.43
3 files changed, 97 insertions, 1 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index 4d4f39077e7e..bd8a78d4518a 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.25 2007/03/22 12:11:46 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.26 2007/10/11 20:26:56 alonbl Exp $
+
+*dazuko-2.3.4 (11 Oct 2007)
+
+ 11 Oct 2007; Alon Bar-Lev <alonbl@gentoo.org> +dazuko-2.3.4.ebuild:
+ Version bump
*dazuko-2.3.3 (22 Mar 2007)
diff --git a/sys-fs/dazuko/dazuko-2.3.4.ebuild b/sys-fs/dazuko/dazuko-2.3.4.ebuild
new file mode 100644
index 000000000000..25be3d54e87b
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.4.ebuild,v 1.1 2007/10/11 20:26:56 alonbl Exp $
+
+inherit linux-mod toolchain-funcs flag-o-matic
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="kernel_linux? ( >=virtual/linux-sources-2.2 )"
+RDEPEND=${DEPEND}
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_setup
+ # kernel settings
+ if [ "${KERNEL}" = "linux" ] && kernel_is le 2 4; then
+ BUILD_TARGETS="all"
+ else
+ CONFIG_CHECK="SECURITY_CAPABILITIES"
+ BUILD_TARGETS="dummy_rule"
+ fi
+ MODULE_NAMES="dazuko(misc:)"
+}
+
+src_compile() {
+ if [ "${KERNEL}" = "FreeBSD" ]; then
+ KERNEL_DIR=/usr/src/sys
+ KBUILD_OUTPUT=/boot/modules
+ MAKE=make
+ fi
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+
+ if [ "${KERNEL}" = "linux" ]; then
+ convert_to_m Makefile
+ linux-mod_src_compile
+ else
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" LDFLAGS="$(raw-ldflags)" || die
+ fi
+
+ emake -C library CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ if [ "${KERNEL}" = "linux" ]; then
+ linux-mod_src_install
+ else
+ insinto /boot/modules
+ doins "${S}"/dazuko.kld
+ exeinto /boot/modules
+ doexe "${S}"/dazuko.ko
+ fi
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+ doins dazuko_events.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
+src_test() {
+ if [ "${EUID}" != 0 ]; then
+ ewarn "Cannot test while not root"
+ else
+ emake test || die "Test failed"
+ fi
+}
+
+pkg_postinst() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postinst
+}
+
+pkg_postrm() {
+ [ "${KERNEL}" = "linux" ] && linux-mod_pkg_postrm
+}
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.4 b/sys-fs/dazuko/files/digest-dazuko-2.3.4
new file mode 100644
index 000000000000..b373e83459a6
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.4
@@ -0,0 +1,3 @@
+MD5 14ae194714584944b983845793daf2a4 dazuko-2.3.4.tar.gz 182144
+RMD160 5cd4c7ab0b945f2df6e0c9be089d91c4a2b86798 dazuko-2.3.4.tar.gz 182144
+SHA256 5ccea045a9f9fbdb3405231090605e8fe7a9359d10e963b87b34bfde810b03fa dazuko-2.3.4.tar.gz 182144