summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-10 23:02:53 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-10 23:02:53 +0000
commitd6ec0fa8686da898023512f9d0315192580c33c0 (patch)
tree5da0cbce408ddf91533a75d62d5aa4057433834d /sys-fs
parentpull in Net_Sieve #129436 (diff)
downloadgentoo-2-d6ec0fa8686da898023512f9d0315192580c33c0.tar.gz
gentoo-2-d6ec0fa8686da898023512f9d0315192580c33c0.tar.bz2
gentoo-2-d6ec0fa8686da898023512f9d0315192580c33c0.zip
Let portage compress the docs #129486 by Stefan de Konink.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/ChangeLog6
-rw-r--r--sys-fs/xfsprogs/files/xfsprogs-2.7.11-no-compress-docs.patch28
-rw-r--r--sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild3
3 files changed, 35 insertions, 2 deletions
diff --git a/sys-fs/xfsprogs/ChangeLog b/sys-fs/xfsprogs/ChangeLog
index 9fcc880f2e78..393e9d45580a 100644
--- a/sys-fs/xfsprogs/ChangeLog
+++ b/sys-fs/xfsprogs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/xfsprogs
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.44 2006/02/19 23:52:35 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/ChangeLog,v 1.45 2006/04/10 23:02:53 vapier Exp $
+
+ 10 Apr 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/xfsprogs-2.7.11-no-compress-docs.patch, xfsprogs-2.7.11.ebuild:
+ Let portage compress the docs #129486 by Stefan de Konink.
19 Feb 2006; Joshua Kinard <kumba@gentoo.org> xfsprogs-2.7.3.ebuild:
Marked stable on mips.
diff --git a/sys-fs/xfsprogs/files/xfsprogs-2.7.11-no-compress-docs.patch b/sys-fs/xfsprogs/files/xfsprogs-2.7.11-no-compress-docs.patch
new file mode 100644
index 000000000000..901b9555decb
--- /dev/null
+++ b/sys-fs/xfsprogs/files/xfsprogs-2.7.11-no-compress-docs.patch
@@ -0,0 +1,28 @@
+let portage compress CHANGES
+
+--- doc/Makefile
++++ doc/Makefile
+@@ -8,16 +8,13 @@
+ LSRCFILES = INSTALL PORTING CHANGES COPYING CREDITS
+ LDIRT = *.gz
+
+-default: CHANGES.gz
++default:
+
+ include $(BUILDRULES)
+
+-CHANGES.gz:
+- $(ZIP) --best -c < CHANGES > $@
+-
+ install: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+- $(INSTALL) -m 644 PORTING CHANGES.gz CREDITS $(PKG_DOC_DIR)
++ $(INSTALL) -m 644 PORTING CHANGES CREDITS $(PKG_DOC_DIR)
+ ifeq ($(PKG_DISTRIBUTION), debian)
+ $(INSTALL) -S CHANGES.gz $(PKG_DOC_DIR)/changelog.gz
+ else
+@@ -25,3 +22,4 @@
+ endif
+
+ install-dev:
++
diff --git a/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild b/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild
index aca241cc83bd..8e7de199ffa9 100644
--- a/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild,v 1.1 2006/01/27 00:46:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/xfsprogs/xfsprogs-2.7.11.ebuild,v 1.2 2006/04/10 23:02:53 vapier Exp $
inherit flag-o-matic eutils
@@ -21,6 +21,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-no-compress-docs.patch #129486
# Inject our own CFLAGS / docpath
sed -i \
-e '/^GCFLAGS/s:-O1::' \