summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-21 07:02:31 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-21 07:02:31 +0000
commitcb5e543a8adff548be3088dba18a977e4753a9d7 (patch)
tree9ea5268495826960aa3dbcd5c7cf8dd46c4a7b5e /sys-fs
parentold (diff)
downloadgentoo-2-cb5e543a8adff548be3088dba18a977e4753a9d7.tar.gz
gentoo-2-cb5e543a8adff548be3088dba18a977e4753a9d7.tar.bz2
gentoo-2-cb5e543a8adff548be3088dba18a977e4753a9d7.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/ChangeLog8
-rw-r--r--sys-fs/mtd-utils/mtd-utils-20080907.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/sys-fs/mtd-utils/ChangeLog b/sys-fs/mtd-utils/ChangeLog
index 555673a595b6..cc953c8ee360 100644
--- a/sys-fs/mtd-utils/ChangeLog
+++ b/sys-fs/mtd-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/mtd-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.14 2008/06/23 00:54:37 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/ChangeLog,v 1.15 2008/09/21 07:02:31 vapier Exp $
+
+*mtd-utils-20080907 (21 Sep 2008)
+
+ 21 Sep 2008; Mike Frysinger <vapier@gentoo.org>
+ +mtd-utils-20080907.ebuild:
+ Version bump.
22 Jun 2008; Zac Medico <zmedico@gentoo.org> mtd-utils-9999.ebuild:
Add -f to rm arguments in src_install since ${D}/usr/include doesn't
diff --git a/sys-fs/mtd-utils/mtd-utils-20080907.ebuild b/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
new file mode 100644
index 000000000000..7e9c3510d7d6
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-20080907.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/mtd-utils/mtd-utils-20080907.ebuild,v 1.1 2008/09/21 07:02:31 vapier Exp $
+
+inherit toolchain-funcs
+
+# Git ID for the snapshot
+MY_PV="${PV}-41c53b6f2d756ae995c3ffa4455576515427c5e0"
+DESCRIPTION="MTD userspace tools, based on GIT snapshot from upstream"
+HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
+SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="xattr"
+
+RDEPEND="!sys-fs/mtd
+ dev-libs/lzo
+ sys-libs/zlib"
+# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
+# And ACL brings in Attr as well.
+DEPEND="${DEPEND}
+ xattr? ( sys-apps/acl )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i 's:-Werror::' $(find . -name Makefile)
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ OPTFLAGS="${CFLAGS}" \
+ $(use xattr && echo WITHOUT_XATTR=1) \
+ || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ newman ubi-utils/doc/unubi.roff unubi.1
+ dodoc *.txt */*.TXT
+ newdoc mkfs.ubifs/README README.mkfs.ubifs
+ newdoc ubi-utils/README README.ubi-utils
+ newdoc ubi-utils/new-utils/README README.new-utils
+ # TODO: check ubi-utils for docs+scripts
+}